Change in libosmo-sccp[master]: enum osmo_sccp_ssn: rename to OSMO_SCCP_SSN_SMLC_BSSAP_LE

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/gerrit-log@lists.osmocom.org/.

neels gerrit-no-reply at lists.osmocom.org
Fri Sep 4 01:33:12 UTC 2020


neels has uploaded this change for review. ( https://gerrit.osmocom.org/c/libosmo-sccp/+/19976 )


Change subject: enum osmo_sccp_ssn: rename to OSMO_SCCP_SSN_SMLC_BSSAP_LE
......................................................................

enum osmo_sccp_ssn: rename to OSMO_SCCP_SSN_SMLC_BSSAP_LE

Quoting 3GPP TS 23.003 8.2:

 1111 1010 BSC (BSSAP-LE);
 1111 1011 MSC (BSSAP-LE);
 1111 1100 SMLC (BSSAP-LE);

Hence the SMLC one should also be named *_BSSAP_LE.

I'm certain no other osmocom code is using this SSN yet, but anyway keep a
backwards compat shim #define.

Change-Id: I3e0c1be0ebbd3883d024174d1e7e9167a8281cfb
---
M include/osmocom/sigtran/sccp_sap.h
1 file changed, 4 insertions(+), 1 deletion(-)



  git pull ssh://gerrit.osmocom.org:29418/libosmo-sccp refs/changes/76/19976/1

diff --git a/include/osmocom/sigtran/sccp_sap.h b/include/osmocom/sigtran/sccp_sap.h
index e012635..817ac45 100644
--- a/include/osmocom/sigtran/sccp_sap.h
+++ b/include/osmocom/sigtran/sccp_sap.h
@@ -131,11 +131,14 @@
 	OSMO_SCCP_SSN_PCAP		= 249,
 	OSMO_SCCP_SSN_BSC_BSSAP_LE	= 250,
 	OSMO_SCCP_SSN_MSC_BSSAP_LE	= 251,
-	OSMO_SCCP_SSN_SMLC_BSSAP	= 252,
+	OSMO_SCCP_SSN_SMLC_BSSAP_LE	= 252,
 	OSMO_SCCP_SSN_BSS_OAM		= 253,
 	OSMO_SCCP_SSN_BSSAP		= 254,
 };
 
+/* legacy shim for name change */
+#define OSMO_SCCP_SSN_SMLC_BSSAP OSMO_SCCP_SSN_SMLC_BSSAP_LE
+
 extern const struct value_string osmo_sccp_ssn_names[];
 static inline const char *osmo_sccp_ssn_name(enum osmo_sccp_ssn val)
 { return get_value_string(osmo_sccp_ssn_names, val); }

-- 
To view, visit https://gerrit.osmocom.org/c/libosmo-sccp/+/19976
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings

Gerrit-Project: libosmo-sccp
Gerrit-Branch: master
Gerrit-Change-Id: I3e0c1be0ebbd3883d024174d1e7e9167a8281cfb
Gerrit-Change-Number: 19976
Gerrit-PatchSet: 1
Gerrit-Owner: neels <nhofmeyr at sysmocom.de>
Gerrit-MessageType: newchange
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/gerrit-log/attachments/20200904/3dc82821/attachment.htm>


More information about the gerrit-log mailing list