Change in osmo-gsm-tester[master]: ms_srs: refactor UE state getter functions

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/gerrit-log@lists.osmocom.org/.

pespin gerrit-no-reply at lists.osmocom.org
Fri May 29 13:43:12 UTC 2020


pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-gsm-tester/+/18535 )

Change subject: ms_srs: refactor UE state getter functions
......................................................................


Patch Set 1:

(2 comments)

https://gerrit.osmocom.org/c/osmo-gsm-tester/+/18535/1/src/osmo_gsm_tester/obj/ms_srs.py 
File src/osmo_gsm_tester/obj/ms_srs.py:

https://gerrit.osmocom.org/c/osmo-gsm-tester/+/18535/1/src/osmo_gsm_tester/obj/ms_srs.py@316 
PS1, Line 316:     def is_rrc_idle(self):
>From follow-up commits, I talked about dropping this API. Simply use not self.is_rrc_connected() directly.


https://gerrit.osmocom.org/c/osmo-gsm-tester/+/18535/1/src/osmo_gsm_tester/obj/ms_srs.py@319 
PS1, Line 319:     def is_emm_registered(self):
> I think we can't compare the 2G(/3G) with the 4G/5G case here. The terms are simply different. […]
So, I propose doing this:
* You can keep the is_rrc_connected() as it is, which is specific to ms_srs.py for now.
* Drop is_rrc_idle()
* Rename ms_ofono.py "is_connected" method to "is_registered" and in all tests under sysmocom/ and doc/examples.
* Set this new "is_registered" method as abstract in ms.py
* When you implement it here (rename is_emm_registered to is_registered), simply add a description explaining it means EMM registered.

What do you think?



-- 
To view, visit https://gerrit.osmocom.org/c/osmo-gsm-tester/+/18535
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings

Gerrit-Project: osmo-gsm-tester
Gerrit-Branch: master
Gerrit-Change-Id: I6cd057e34b4df6a1a73695355dd6406d7e039546
Gerrit-Change-Number: 18535
Gerrit-PatchSet: 1
Gerrit-Owner: srs_andre <andre at softwareradiosystems.com>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: pespin <pespin at sysmocom.de>
Gerrit-Reviewer: srs_andre <andre at softwareradiosystems.com>
Gerrit-Comment-Date: Fri, 29 May 2020 13:43:12 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: srs_andre <andre at softwareradiosystems.com>
Comment-In-Reply-To: pespin <pespin at sysmocom.de>
Gerrit-MessageType: comment
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/gerrit-log/attachments/20200529/ddbab522/attachment.htm>


More information about the gerrit-log mailing list