Change in osmo-bsc[master]: stats: Add a stats gauge for the MSC link status.

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/gerrit-log@lists.osmocom.org/.

ipse gerrit-no-reply at lists.osmocom.org
Thu May 7 13:10:38 UTC 2020


ipse has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-bsc/+/18092 )

Change subject: stats: Add a stats gauge for the MSC link status.
......................................................................


Patch Set 2:

(4 comments)

https://gerrit.osmocom.org/c/osmo-bsc/+/18092/1/include/osmocom/bsc/gsm_data.h 
File include/osmocom/bsc/gsm_data.h:

https://gerrit.osmocom.org/c/osmo-bsc/+/18092/1/include/osmocom/bsc/gsm_data.h@1557 
PS1, Line 1557: enum {
> can we have a name for this enum? for the sake of being able to refer to it. […]
These enum's are not named in other parts of the code, so I was following the de-facto convention. I can add a name for this if you could suggest one - I'm not sure of Osmocom naming conventions.


https://gerrit.osmocom.org/c/osmo-bsc/+/18092/1/include/osmocom/bsc/gsm_data.h@1588 
PS1, Line 1588: 	struct osmo_stat_item_group *bsc_statg;
> worth adding a comment on top explaining what's used for now that you are adding it.
Ack


https://gerrit.osmocom.org/c/osmo-bsc/+/18092/1/src/osmo-bsc/a_reset.c 
File src/osmo-bsc/a_reset.c:

https://gerrit.osmocom.org/c/osmo-bsc/+/18092/1/src/osmo-bsc/a_reset.c@75 
PS1, Line 75: 	LOGPFSML(fi, LOGL_NOTICE, "SIGTRAN connection succeeded.\n");
> Ugh, why do we have a connection successed on a "disc" (disconnect?" callback?
Because this is an "action" callback and the only event which can hit this cb changes the state to "connected". But I agree this is confusing, so I've changed this to be more clear with "onenter" CB in the next patch version. I just didn't know about "onenter" when I was writing this.


https://gerrit.osmocom.org/c/osmo-bsc/+/18092/1/src/osmo-bsc/bsc_init.c 
File src/osmo-bsc/bsc_init.c:

https://gerrit.osmocom.org/c/osmo-bsc/+/18092/1/src/osmo-bsc/bsc_init.c@48 
PS1, Line 48: 	{ "msc_link", "MSC link status.", "", 16, 0 },
> Do we add dots at the end of descriptions? probably not (please check).

Historically there were dots, but I agree this is not correct and I'll remove them from new ones.

> Last param is a pointer, so NULL fits better.

No, it's a default value:
/*! Statistics item description */
struct osmo_stat_item_desc {
	const char *name;	/*!< name of the item */
	const char *description;/*!< description of the item */
	const char *unit;	/*!< unit of a value */
	unsigned int num_values;/*!< number of values to store in FIFO */
	int32_t default_value;	/*!< default value */
};



-- 
To view, visit https://gerrit.osmocom.org/c/osmo-bsc/+/18092
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings

Gerrit-Project: osmo-bsc
Gerrit-Branch: master
Gerrit-Change-Id: Ibe4b29056ba704a27b925cfdba49f343ee34f428
Gerrit-Change-Number: 18092
Gerrit-PatchSet: 2
Gerrit-Owner: ipse <Alexander.Chemeris at gmail.com>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: ipse <Alexander.Chemeris at gmail.com>
Gerrit-CC: pespin <pespin at sysmocom.de>
Gerrit-Comment-Date: Thu, 07 May 2020 13:10:38 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: pespin <pespin at sysmocom.de>
Gerrit-MessageType: comment
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/gerrit-log/attachments/20200507/5b8a0998/attachment.htm>


More information about the gerrit-log mailing list