Change in osmo-gsm-tester[master]: ms_driver: Rename method to hopefully be more clear

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/gerrit-log@lists.osmocom.org/.

Holger Freyther gerrit-no-reply at lists.osmocom.org
Mon Feb 25 10:49:48 UTC 2019


Holger Freyther has submitted this change and it was merged. ( https://gerrit.osmocom.org/13028 )

Change subject: ms_driver: Rename method to hopefully be more clear
......................................................................

ms_driver: Rename method to hopefully be more clear

This is finding min/max in a dataset. Call it like this and update
the caller.

Change-Id: Ic7f5cd34639f897e460ca1edcb4f9b6df44683e9
---
M src/osmo_ms_driver/location_update_test.py
1 file changed, 2 insertions(+), 2 deletions(-)

Approvals:
  Jenkins Builder: Verified
  Pau Espin Pedrol: Looks good to me, approved



diff --git a/src/osmo_ms_driver/location_update_test.py b/src/osmo_ms_driver/location_update_test.py
index 90e405e..8500607 100644
--- a/src/osmo_ms_driver/location_update_test.py
+++ b/src/osmo_ms_driver/location_update_test.py
@@ -198,7 +198,7 @@
     def all_completed(self):
         return self._outstanding == 0
 
-    def results_min_max(self, results):
+    def find_min_max(self, results):
         min_value = max_value = None
         for result in results:
             if min_value is None or result.lu_delay() < min_value:
@@ -209,7 +209,7 @@
 
     def print_stats(self):
         all_completed = self.all_completed()
-        min_value, max_value = self.results_min_max(filter(lambda x: x.has_lu_time(), self._results.values()))
+        min_value, max_value = self.find_min_max(filter(lambda x: x.has_lu_time(), self._results.values()))
 
         self.log("Tests done", all_completed=all_completed,
                     min=min_value, max=max_value)

-- 
To view, visit https://gerrit.osmocom.org/13028
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings

Gerrit-Project: osmo-gsm-tester
Gerrit-Branch: master
Gerrit-MessageType: merged
Gerrit-Change-Id: Ic7f5cd34639f897e460ca1edcb4f9b6df44683e9
Gerrit-Change-Number: 13028
Gerrit-PatchSet: 1
Gerrit-Owner: Holger Freyther <holger at freyther.de>
Gerrit-Reviewer: Holger Freyther <holger at freyther.de>
Gerrit-Reviewer: Jenkins Builder (1000002)
Gerrit-Reviewer: Pau Espin Pedrol <pespin at sysmocom.de>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/gerrit-log/attachments/20190225/7953008c/attachment.htm>


More information about the gerrit-log mailing list