Change in osmo-ttcn3-hacks[master]: msc/USSD: add test cases with network-initiaded SS/USSD

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/gerrit-log@lists.osmocom.org/.

Harald Welte gerrit-no-reply at lists.osmocom.org
Mon Jun 25 10:35:56 UTC 2018


Harald Welte has posted comments on this change. ( https://gerrit.osmocom.org/9686 )

Change subject: msc/USSD: add test cases with network-initiaded SS/USSD
......................................................................


Patch Set 4: Code-Review+1

(1 comment)

https://gerrit.osmocom.org/#/c/9686/4/msc/MSC_Tests.ttcn
File msc/MSC_Tests.ttcn:

https://gerrit.osmocom.org/#/c/9686/4/msc/MSC_Tests.ttcn@2273
PS4, Line 2273: alt {
              : 	[] BSSAP.receive(tr_BSSMAP_Paging(g_pars.imsi)) {
              : 		setverdict(pass);
              : 		}
              : 	[] BSSAP.receive {
              : 		setverdict(fail, "Unknown/unexpected BSSAP received");
              : 		self.stop;
              : 		}
              : 	[] GSUP.receive {
              : 		setverdict(fail, "Unexpected GSUP message received");
              : 		self.stop;
              : 		}
              : 	}
The fact that you still have those alt-clauses here means that somehow the abstraction level chosen doesn't work.  You have not implemented the altstep suggestion that I hinted in a previous comment and instead introduced functions lie f_expect_bssap().  But then, that function works only for DTAP, so you need to open-code this again here.  The detailed design is up to you, but I think it would be good t o generalize this, i.e. either have a f_expect_bssap() that works for both dtap + bssmap, or have separate expect functions.  And independent of all of this, the "[] foo.receive {setverdict(fail); self.stop}" which are repeated in every of those functions could be an altstep, whcih is then invoked from every f_expect_ function, further  reducing code duplication.



-- 
To view, visit https://gerrit.osmocom.org/9686
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings

Gerrit-Project: osmo-ttcn3-hacks
Gerrit-Branch: master
Gerrit-MessageType: comment
Gerrit-Change-Id: I073893c6e11be27e9e36f98f11c1491d0c173985
Gerrit-Change-Number: 9686
Gerrit-PatchSet: 4
Gerrit-Owner: Vadim Yanitskiy <axilirator at gmail.com>
Gerrit-Reviewer: Harald Welte <laforge at gnumonks.org>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: Vadim Yanitskiy <axilirator at gmail.com>
Gerrit-Comment-Date: Mon, 25 Jun 2018 10:35:56 +0000
Gerrit-HasComments: Yes
Gerrit-HasLabels: Yes
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/gerrit-log/attachments/20180625/62de476e/attachment.htm>


More information about the gerrit-log mailing list