osmo-gsm-tester[master]: debug: Add voicecall related method to interactive shell

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/gerrit-log@lists.osmocom.org/.

Neels Hofmeyr gerrit-no-reply at lists.osmocom.org
Wed Oct 11 20:24:54 UTC 2017


Patch Set 1: Code-Review+2

(9 comments)

some more nitpicks...

https://gerrit.osmocom.org/#/c/4151/1/suites/aoip_debug/interactive.py
File suites/aoip_debug/interactive.py:

Line 26:   cmd = prompt('Enter command: (q)uit (s)ms (g)et-registered (w)ait-registered, call-list [<ms_msisdn>], call-dial <src_msisdn> <dst_msisdn>, call-answer <ms_msisdn> <call_id>, call-hangup <ms_msisdn> <call_id>')
that prompt line is getting awfully long. We may need to a) split it up or b) move to a 'help' command


Line 52:   elif cmd.startswith('call-list'):
evangelism: before, commands could be abbreviated to their least unique length (and so far it was unique from the first character). these added commands change that premise... cleaner would be to add a mechanism that finds an unambiguous match above. But then again... nevermind...


Line 58:           print('call_list: %r' % ms.call_id_list())
nitpick: command is 'call-list', py function is call_id_list(), yet this prints 'call_list' :)


Line 65:         print('dial %s->%s, %s' % (params[1],params[2],str(mo.call_dial(params[2]))))
'dialing'? Might be better to first print 'dialing' and then start dialing? With this code here, first dial and only print the result when the function has returned.


Line 69:       continue
would make more readable:

  ms_msisdn, call_id = params


Line 72:         print('answer %s' % params[2])
'answering'?


Line 77:       continue
would make more readable:

  ms_msisdn, call_id = params


Line 80:         print('hang up %s' % params[2])
'hanging up' ?


https://gerrit.osmocom.org/#/c/4151/1/suites/debug/interactive.py
File suites/debug/interactive.py:

Line 45:   elif cmd.startswith('call-list'):
oh damn, are we really duplicating all this? we should fix that...


-- 
To view, visit https://gerrit.osmocom.org/4151
To unsubscribe, visit https://gerrit.osmocom.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: Id2df68bf4fba0fb542eebdeb515a3dac6d5e575e
Gerrit-PatchSet: 1
Gerrit-Project: osmo-gsm-tester
Gerrit-Branch: master
Gerrit-Owner: Pau Espin Pedrol <pespin at sysmocom.de>
Gerrit-Reviewer: Harald Welte <laforge at gnumonks.org>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: Neels Hofmeyr <nhofmeyr at sysmocom.de>
Gerrit-HasComments: Yes



More information about the gerrit-log mailing list