osmo-pcu[master]: PDCH allocation across two TRX

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/gerrit-log@lists.osmocom.org/.

Neels Hofmeyr gerrit-no-reply at lists.osmocom.org
Sat Dec 31 18:09:00 UTC 2016


Patch Set 2:

(8 comments)

just a few remarks...

https://gerrit.osmocom.org/#/c/1512/2/src/bts.cpp
File src/bts.cpp:

Line 417:  */
> Add doxygen with explanation of the meaning of each function parameter and 
though this particular one is not being added by this patch, I agree that this as well as the new functions could use more detailed docs.


Line 422: 	uint32_t free_tfis = 0xffffffff;
> Where does this magic value comes from? Can you use some define instead?
(makes sense to me: all bits set in a uint32_t flagging all as free)


Line 433: 	if (use_trx >= 0)
> If it only used as true/false than it should be bool.
use_trx indicates a TRX number, so it's not bool


Line 435: 	else
> If I got this right than you can check _trx for NULL and use 1 function par
no, _trx needs to be returned in all cases. Also not related to this patch...


Line 462:  * indicate errors.
document the size of the *_trx array


https://gerrit.osmocom.org/#/c/1512/2/src/gprs_rlcmac_ts_alloc.cpp
File src/gprs_rlcmac_ts_alloc.cpp:

Line 386: 	LOGP(DRLCMAC, LOGL_DEBUG, " Use trx = %d \n",use_trx);
what with the whitespaces at start and end of log lines?


https://gerrit.osmocom.org/#/c/1512/2/tests/tbf/TbfTest.cpp
File tests/tbf/TbfTest.cpp:

Line 2852: 	dl_tbf = tbf_alloc_dl_tbf(the_bts.bts_data(), NULL, trx_no,
store the_bts.bts_data() in a local var with a short name


Line 2856: 		ms_class, egprs_ms_class, 1);
it would be far more readable to declare a macro containing the tbf_alloc and assert, and just call that macro repeatedly with alternating argument.

  ASSERT_TBF_ALLOC_ON_TRX(0);
  ASSERT_TBF_ALLOC_ON_TRX(1);
  ASSERT_TBF_ALLOC_ON_TRX(0);
  ASSERT_TBF_ALLOC_ON_TRX(1);
  ...


-- 
To view, visit https://gerrit.osmocom.org/1512
To unsubscribe, visit https://gerrit.osmocom.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I222c3340872ffa1dd6e8fabe5276d793e660f67d
Gerrit-PatchSet: 2
Gerrit-Project: osmo-pcu
Gerrit-Branch: master
Gerrit-Owner: arvind.sirsikar <arvind.sirsikar at radisys.com>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: Max <msuraev at sysmocom.de>
Gerrit-Reviewer: Neels Hofmeyr <nhofmeyr at sysmocom.de>
Gerrit-HasComments: Yes



More information about the gerrit-log mailing list