osmo-pcu[master]: PDCH allocation across two TRX

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/gerrit-log@lists.osmocom.org/.

Max gerrit-no-reply at lists.osmocom.org
Fri Dec 30 13:44:10 UTC 2016


Patch Set 2: Code-Review-1

(5 comments)

The same comments apply to pretty much all files.

https://gerrit.osmocom.org/#/c/1512/2/src/bts.cpp
File src/bts.cpp:

Line 417:  */
Add doxygen with explanation of the meaning of each function parameter and return value.


Line 422: 	uint32_t free_tfis = 0xffffffff;
Where does this magic value comes from? Can you use some define instead?


Line 433: 	if (use_trx >= 0)
If it only used as true/false than it should be bool.


Line 435: 	else
If I got this right than you can check _trx for NULL and use 1 function parameter instead of 2.


Line 554: 	trx_from = 0;
You can put this directly into for () if it's not used anywhere else.


-- 
To view, visit https://gerrit.osmocom.org/1512
To unsubscribe, visit https://gerrit.osmocom.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I222c3340872ffa1dd6e8fabe5276d793e660f67d
Gerrit-PatchSet: 2
Gerrit-Project: osmo-pcu
Gerrit-Branch: master
Gerrit-Owner: arvind.sirsikar <arvind.sirsikar at radisys.com>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: Max <msuraev at sysmocom.de>
Gerrit-HasComments: Yes



More information about the gerrit-log mailing list