PCU socket has LOST connection

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/baseband-devel@lists.osmocom.org/.

Mario Lucas mariolucas75 at mail.ru
Sun Sep 5 18:57:33 UTC 2021

Dear All,
I try to run a virtual BTS:
systemctl start osmo-stp
systemctl start osmo-hlr
systemctl start osmo-msc
systemctl start osmo-bsc
and finally i run osmo-bts-virtual…. but i am getting following outcome:
DOML <0001> oml.c:91 OC=GPRS-CELL INST=(00,ff,ff): Sending PCU version report to BSC: PCU socket has LOST connection
DPCU <0009> pcu_sock.c:1084 PCU socket connected to external PCU
DPCU <0009> pcu_sock.c:967 Received 212 bytes on PCU Socket, but primitive size is 1006, discarding
DPCU <0009> pcu_sock.c:895 PCU socket has LOST connection
I tried to run osmo-pcu (I thought may be this will resole above issue) but it keeps saying:

<000b> gprs_ns.c:322 NSVCI=65534 Creating NS-VC with Signal weight 1, Data weight 1
<000e> telnet_interface.c:104 Available via telnet 4240
<0001> osmobts_sock.cpp:224 Opening OsmoPCU L1 interface to OsmoBTS
<0001> osmobts_sock.cpp:248 osmo-bts PCU socket /tmp/pcu_bts has been connected
<0001> pcu_l1_if.cpp:114 Sending 0.8.0 TXT as PCU_VERSION to BTS
PCU interface version number of BTS (10) is different (9).
Please re-compile!
I have
OsmoPCU version 0.8.0
OsmoBTS version
Would you kindly advise whats going on please….
As i understand osmo-pcu is to implement GPRS into my GSM network… ok but if i dont want GPRS implemented thus i dont need PCU …. can i run virtual bts without this PCU things ?
pls help …..
Mario Lucas
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/baseband-devel/attachments/20210905/e8a36ef6/attachment.htm>

More information about the baseband-devel mailing list