Osmocon failed to flash

Felix Angga felangga at gmail.com
Sun Dec 3 11:08:04 UTC 2017

Yes I've tried using xor and without xor.
I'm running on bare hardware. Linux mint 18.
Do I need to configure baud rate? Or the default 115200 should be OK?
Hmm okay, i'll try on other computer.

Btw, will it be affected with the length of the cable?

On Dec 3, 2017 6:00 PM, "Harald Welte" <laforge at gnumonks.org> wrote:

On Sat, Dec 02, 2017 at 10:43:40PM +0700, felangga at gmail.com wrote:
> $ host/osmocon/osmocon -p /dev/ttyUSB0 -m c123xor target/firmware/board/
> compal_e88/hello_world.compalram.bin -c

have you tried 'c123' without XOR?  Are you running in some kind of VM
or on bare hardware?  The timing is very critical, and some combinations
of hardware + drivers + software are not able to fulfill the strict
timing requirements.

In case of doubt, try using a different computer.

- Harald Welte <laforge at gnumonks.org>           http://laforge.gnumonks.org/
"Privacy in residential applications is a desirable marketing option."
                                                  (ETSI EN 300 175-7 Ch. A6)
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/baseband-devel/attachments/20171203/5e998579/attachment.html>

More information about the baseband-devel mailing list