OsmocomBB on Openmoko GTA02

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/baseband-devel@lists.osmocom.org/.

Cosmin - Ioan PETRI?OR cosmin_ioan.petrisor at cti.pub.ro
Sat Jun 18 13:48:20 UTC 2016

Hi guys,

I have a lot of problems using osmocom-bb with an Openmoko GTA02. First of all, I followed all the instructions from here [1] and uploaded layer1.highram.bin via external jack serial port (second tutorial). Well, after the firmware is downloaded on the phone osmocon prints:


Finished, sent 54 blocks in total

Received branch ack, your code is running now!


and nothing is printed anymore. Moreover, I see no activity on the serial port, all LEDs on my USB adapter being off.

When I try to run cell_log from my PC, it prints the following error message and blocks / does nothing:


Failed to connect to '/tmp/osmocom_sap'.

Failed during sap_open(), no SIM reader

<000e> cell_log.c:804 Scanner initialized

Mobile initialized, please start phone now!


I've read about this error and figured out that it is not fatal, but still cell_log doesn't work, nor does the 'mobile' application. I tried the code from master and from sylvain/testing branch and I uncommented "CONFIG_TX_ENABLE". I even tried hello_world.highram.bin and that doesn't print anything after loading it. I don't know what to do anymore.

[1] http://bb.osmocom.org/trac/wiki/OpenMoko#no1
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/baseband-devel/attachments/20160618/766d141f/attachment.htm>

More information about the baseband-devel mailing list