Osmocom: assembler errors (swab.h)

neetesh saxena saxenaneetesh061 at rediffmail.com
Tue Jan 7 10:33:00 UTC 2014


I have tried everything which I can. 
I removed the installtion (dependencies) and libosmocore, osmocom-bb, gnu-arm.

Now I have installed again all.
I added the PATH to bashrc (by opening it and paste the path) along with typing it on terminal (as suggested on wiki osmocom-bb). But I am still getting the error.

"swab.h:32: error: no such instruction: 'eor %edx, %ecx, %ecx, ror'" and 

any suggestion on it?

With regards

Neetesh Saxena...

From: Steve Markgraf <steve at steve-m.de>
Sent: Mon, 06 Jan 2014 00:21:23 
To: neetesh saxena <saxenaneetesh061 at rediffmail.com>, Andreas Eversberg <andreas at eversberg.eu>
Cc: baseband-devel <baseband-devel at lists.osmocom.org>
Subject: Re: Osmocom: assembler errors (swab.h)

On 05.01.2014 10:03, neetesh saxena wrote:

> I have already set the path of arm-elf-gcc.

> But I am still getting the same error. Is there any command or procedure

> by which I can completely remove this installation so that I can try as

> a fresh one.

> _Neetesh_

If you tried building without the toolchain in place, you have to do a

fresh clone of the git repo, or make sure to delete everything that

automake and gcc created.



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/baseband-devel/attachments/20140107/faf04461/attachment.html>

More information about the baseband-devel mailing list