Flashing Layer1 to GTA02

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/baseband-devel@lists.osmocom.org/.

Arno Onken asnelt at asnelt.org
Wed Jun 20 20:07:12 UTC 2012

Hello everyone!

I got osmocom-bb running on a gta02 with a self-built Debian image.
osmocon-bb was compiled natively on the gta02. Everything works great using:

$ ./osmocon -i 13 -m romload -p /dev/ttySAC0 layer1.highram.bin

as described at:


It bugs me, however, that the proprietary openmoko 11 firmware is still
lingering in the baseband flash. So I would like to replace it
permanently with the osmocom-bb layer 1 firmware. That didn't work so far.

First, I attempted to use the FLUID binary to flash layer1.highram.bin.
The manual firmware update that is described at:


suggests to use the FLUID binary from the package:


I tried to run:

$ FLUID_PORT=/dev/ttySAC0 ./fluid.exe -oo -od13,13 -b 115200 -f

This gives me:

FLUID Revision 2.27, (23 Aug 2004). Copyright Texas Instruments, 2001-2004.
Reading image file:
Illegal hex line:
 ERROR(55): File format/syntax error

I also played with the options but to no avail. So apparently fluid
expects the firmware image to be in a particular format.

Then I tried the osmoload utility. For that I started osmocon with:

$ ./osmocon -i 13 -l /tmp/osmocom_loader -m romload -p /dev/ttySAC0

osmocon then says:

Sending Calypso romloader beacon...

On another console I then turned on the GSM device and tried to request
information about flash using:

$ ./osmoload -l /tmp/osmocom_loader finfo

This gives me:

Requesting flash layout info
Query timed out.

What am I doing wrong? Are there fundamental reasons why this cannot
work? Any hints would be much appreciated!



More information about the baseband-devel mailing list