about osmocon on gta02 (Solved)

Sylvain Munaut 246tnt at gmail.com
Thu Jun 14 11:09:10 UTC 2012


>        I spend one day, finally solved it myself.
>        1) i checked the schematic of gta02 carefully, and found the PCF50633 use GPIO2(gsm_on)
>         to control the power of GSM actually, and it have a test point H-TP1706.
>        2) i disassembled my gta02, then line out the H-TP1706 to my oscilloscope, i found the
>        gsm_on signal always LOW 1s, and HIGH 4.2s, it's very strange.
>        3) i checked the service list, i found the fsogsmd (it's ogsmd?), maybe it's the background
>         program. but i can't kill it.
>        4) finally, i try to set "disable = 0" in /etc/frameworkd.conf, reboot, my god, it solved.
>        but the http://bb.osmocom.org/trac/wiki/OpenMoko only says:
>                “disable ogsmd, ousaged, ophoned via /etc/frameworkd.conf”
>        i always think "disable = 1" should DISABLE it.
>        but actually, "disable = 0" = DISABLE it; and "disable = 1" = ENABLE it? why
>        it misleaded me so long, anybody can change it? thanks.

Could you update the wiki with your findings please ?

Request an account to Harald if you don't already have one.

(should we have some sort of 'guest' account ? I don't mean open
without auth but with a public login/pass)



More information about the baseband-devel mailing list