about osmocon on gta02

Aegean Chou aegean2000 at 21cn.com
Thu Jun 14 01:40:32 UTC 2012

Dear lists,

	i want porting rssi and osmocon to GTA02, let them run on GTA02 stand-alone.
	then i'll try to write a program to decoding the received data.

	i already cross-compiled the latest osmocon to GTA02,
	then i disabled "ogsmd,ousaged and ophoned" in /etc/frameworkd.conf (actually, them are disabled default),
	and i commented "device_port and modem_access" in fsogsmd.conf to disable everything accessed to the modem,
	after rebooting, the "fuser /dev/ttySAC0" shows none.

	but when i use "./osmocon -i 13 -m romload -p /dev/ttySAC0 rssi.highram.bin", and 
	"echo 0 > /sys/bus/platform/devices/gta02-pm-gsm.0/power_on && echo 1 > ..."
										  /\ my SHR kernel use this device name for GSM power
	the osmocon always stalls about at the block 40, for example: 	
		... ...
		Preparing block 39, block checksum is 0x4c 
		handle_write_block(): 1024 bytes (1024/1024)
		handle_write_block(): Block 39 finished
		Received block ack from phone
		Preparing block 40, block checksum is 0xd5 
		handle_write_block(): 1024 bytes (1024/1024)
		handle_write_block(): Block 40 finished
	and i found that the osmocon start to download codes before my "GSM power reset", very strange,

	i tried the latest "SHR-core 20120427" and "unstable SHR-lite 20110822",
	i searched the list log, found "Dave" encounter the same problem, but he solved it after "re-flashing of the phone"
	i re-flashed the GSM firmware to latest Moko11 (before it's Moko10), but it's the same.

	BTW, i found that it always shows '1' when "cat /sys/bus/platform/devices/gta02-pm-gsm.0/power_on"
	even after "echo 0 >/sys/bus/platform/devices/gta02-pm-gsm.0/power_on", what's wrong?

	anyone can help help me?
	thanks very much.

Best Regards

More information about the baseband-devel mailing list