key generation on SIM failed (cause 2)

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at

Alojzij Sinur Alojzij.Sinur at
Thu Apr 5 12:23:15 UTC 2012


we do not have simtrace. Yet.
When we receive simtrace we will be able to read and update you with captures of what is on wire.

We can spare the SIM. It is a prepaid SIM. Why?



-----Original Message-----
From: Sylvain Munaut [mailto:246tnt at] 
Sent: Thursday, April 05, 2012 2:16 PM
To: Alojzij Sinur
Cc: baseband-devel at; Jaka Nemanic
Subject: Re: key generation on SIM failed (cause 2)


> SIM is new. It works if you start phone without osmocom. And It also 
> works if you start without osmocom and when SIM logs into network you 
> restart the phone with osmocom.
> We tried several new cards and there was always same result. There is 
> also no PIN set up (SIM is not locked). We tried with USIM.
> When we try old cards (>2 years old) osmocom works without problem.
> Have you ever encountered this kind of trouble? Is there any fix for it?

Interesting. Purely from the "symptoms", I'd guess that the sim starts in USIM mode and somehow needs to switch into SIM mode to work with plain old GSM.
My understanding is that the SIM should do that on its own, but apparently doesn't. And then when you start the official fw, it's properly switched to SIM mode and then you can start osmocom. (I guess maybe capacitors keep VCC high enough for the sim to survive a reboot ? altough it still should be reset).

Just a theory ... (and not a perfect one at that).

Do you have a simtrace to make captures of what's on the wire when talking to the original fw / osmocom and compare ?
Can you spare a SIM ?



More information about the baseband-devel mailing list