key generation on SIM failed (cause 2)

Alojzij Sinur Alojzij.Sinur at
Thu Apr 5 11:44:00 UTC 2012


I have a question.

When using osmocombb with C118, we are getting error when SIM tries to authenticate itself to the network.
Here are the messages:

<0005> gsm48_mm.c:3902 (ms 1) Received 'RR_DATA_IND' from RR in state location updating initiated (sapi 0)
<0005> gsm48_mm.c:4091 (ms 1) Received 'MT_MM_AUTH_REQ' in MM state location updating initiated
<0005> gsm48_mm.c:1637 AUTHENTICATION REQUEST (seq 2)
<0005> subscriber.c:955 Generating KEY at SIM
<000f> sim.c:209 got new job: SIM_JOB_RUN_GSM_ALGO (handle=00000006)
<000f> sim.c:697 go MF <000f> sim.c:241 SELECT (file=0x3f00)
<000f> sim.c:187 sending APDU (class 0xa0, ins 0xa4)
<000f> sim.c:876 received APDU (len=0 sw1=0x00 sw2=0x00)
<000f> sim.c:952 command failed
<000f> sim.c:151 sending result to callback function (type=1)
<0005> subscriber.c:990 key generation on SIM failed (cause 2)

SIM is new. It works if you start phone without osmocom. And It also works if you start without osmocom and when SIM logs into network you restart the phone with osmocom.
We tried several new cards and there was always same result. There is also no PIN set up (SIM is not locked). We tried with USIM.
When we try old cards (>2 years old) osmocom works without problem.

Have you ever encountered this kind of trouble? Is there any fix for it?

Thank you.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the baseband-devel mailing list