Build fails on OSX Lion

Lukas Kuzmiak lukash at backstep.net
Fri Oct 21 15:43:10 UTC 2011


There has been a patch from Richard James already, i'm including the patch
he sent to baseband-devel in September, however i never managed to get it
work (there are couple of typos in the patch), after i fixed those and
changed -m c123xor to -m c123 firmware only loads in 1024b parts and then
fails after loading.

I'm just sending it over to consider the way to handle serial ports on OS
X, not sure what's better, this patch looked more OS X native rather than
specifying those linux headers, but didn't work properly for me.

I'll be happy to test/debug on OS X 10.7 or 10.6 if you've got some idea
what could be wrong, OS X kernel is a bit of a mystery for me.

cheers,
lukash

On Fri, Oct 21, 2011 at 3:24 PM, Harald Welte <laforge at gnumonks.org> wrote:

> Hi Bjoern,
>
> On Fri, Oct 21, 2011 at 11:45:46AM +0000, Bjoern Kerler wrote:
> > In serial.c, just change :
> > between
>
> would you mind submitting a proper patch, i.e. using autotools to detect
> the presence of OSX header files and using the right include file in
> that case?
>
> --
> - Harald Welte <laforge at gnumonks.org>
> http://laforge.gnumonks.org/
>
> ============================================================================
> "Privacy in residential applications is a desirable marketing option."
>                                                  (ETSI EN 300 175-7 Ch. A6)
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/baseband-devel/attachments/20111021/8a179220/attachment.html>


More information about the baseband-devel mailing list