burst_ind not working

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/baseband-devel@lists.osmocom.org/.

Dario Lombardo dario.lombardo at libero.it
Mon Nov 14 10:06:09 UTC 2011

I have pulled the latest version and everything works now. If I run
ccch_scan (gprs decoding patch applied) I have the bursts.
But when I run the gprs decoder, I got

Type not handled! 40

If I try one the sample .dat files provided by srlabs.de, the decode is ok
and I see the datagrams on wireshark.

This message shows an unsupported message type. Can be due to the noise on
the phone? I have observed the same behaviour with an original phone and a
modified (filters changed) one, but this should not matter.

Can someone help me?

On Fri, Nov 11, 2011 at 12:04 PM, Sylvain Munaut <246tnt at gmail.com> wrote:

> Hi,
> > I'm not able to use cell_log under the burst_ind branch.
> Yes, it's broken right now.
> Either revert the last commit, or cherry-pick
> 4789b4a6627b452041b57f81ea91878de666bcc2 (which is in master but not
> burst_ind yet)
> Cheers,
>    Sylvain
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/baseband-devel/attachments/20111114/3815b32b/attachment.htm>

More information about the baseband-devel mailing list