cp2102 (betemcu, B75937)

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/baseband-devel@lists.osmocom.org/.

R M rm.engineer84 at gmail.com
Tue Nov 8 17:27:50 UTC 2011


Did it work on the Windows machine?

I am also using a windows box for running Osmocombb.

My machine is a DELL Vostro 3500 and has an i3 processor.

I am running Windows 7 64 bit. I am using cygwin for compilation.

I am facing timing issues.  I am able to download the Hello World code
just once in 10 tries.

Rest of the 9 times I get ftmtool error.

I am using the ftdi cable mentioned in the wiki.

My cable is a bit long, its about 2 meters.

Is this a cause of the issue?

I downloaded the drivers from the FTDI site.

My laptop has a in-built webcam. This web cam is hard wired to the usb hub.

I ran USBView provided by FTDI.This tool lists all the devices
connected to the usb bus.

 It shows that the FTDI usb serial converter is also connected to the
same usb hub as the inbuilt web cam.

I have not turned on the web cam though.

Does this thing slow down the usb bus even if the web cam is not turned on?

I have even tried to shut down all the unwanted process but still the
same thing. There is no improvement.

I have tried to change the latency timer from the default 16ms to 4ms.
Still no results.

I have commented out the printf statements like

Received 1 byte from modem....

Still there is no improvement.

I have also tried other suggestions suggested by steve in the mailing
list archives for timing issues.

Still no luck.

Can you please let me know what is your machine configuration ?

Are you using cywin or mingw for compiling ?
(I am asking this because you said you used com1 on a windows box.)

Are you also facing timing issues ? How did you resolve your timing issues?


On Tue, Nov 8, 2011 at 11:48 AM, lonelysurfer <lonelysurfer at web.de> wrote:
> i checked the silicon laboratories documentation of the cp2102 and i noticed
> that the TXD- and RXD-pins are interchanged. TXD and RXD are wrong
> labeled!!!
> After correcting this these cp2102-adapters are working :-)
> --
> View this message in context: http://baseband-devel.722152.n3.nabble.com/cp2102-betemcu-B75937-tp3489336p3489415.html
> Sent from the baseband-devel mailing list archive at Nabble.com.

More information about the baseband-devel mailing list