[PATCH] target/boards: add infrastructure for loaders for Mediatek platforms

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/baseband-devel@lists.osmocom.org/.

Michael Grzeschik mgr at xviews.de
Fri Apr 29 13:13:15 UTC 2011


Hi,

since Wolfram's account is broken at the moment, he asked me to post his
response :) Please CC wsa at pengutronix.de to further replies. Thanks!

On Thu, Apr 28, 2011 at 10:15:31PM +0200, Sylvain Munaut wrote:
> Hi,
> 
> 
> There also seems to be compal references left at various places.
> 
> (just grep for compal / calypso to find them).


Hi Sylvain,

thanks for the review!

 >>   .../board/mediatek/exceptions_redirected.S         |   20 +
 >
 > Mmm, is there also a interrupt redirection on the MTK like on the
 > Calypso ? Or is it just some hack left over ?

I am not that deep into the original ROM yet. I mainly ported the branch 
forward taking care of not changing the behaviour of the code. Seeing 
that the redirected vectors have a section in the linker script, I did 
not dare to remove them yet. I can try, though, interrupts are not used 
yet and the abort handler is hardly useful.

> There also seems to be compal references left at various places.

Let's see:

$ grep compal <patch>

+.section .compal.header

I did not change this intentionally. Because it _is_ the compal header 
and nothing custom. It is not used yet, but I want to change that. It 
could simply go as well.

+    /* compal-loaded binary: our text, initialized data */
+    /* compal-loaded binary: our unitialized data, stacks, heap */
+    .compal.loader (NOLOAD) : { . = 0x1400; } > LRAM

Those can simply be renamed.

$ grep calypso <patch>

+# (should not use libcalypso; needed functionality should be refactored 
(yeah, unlikely, I know))
+ANY_APP_LIBS+=calypso/libcalypso.a lib/libmini.a comm/libcomm.a
+-include calypso/Makefile

Well, libcalypso stuff is currently leaking in from a number of places 
(e.g. libcomm calls the backlight). Can we just keep it for now?

+#include <calypso/uart.h>
+#include <calypso/uart.h>
+/* We emulate the calypso interface */
+#include <calypso/uart.h>

Shall we just make it "uart.h"? I don't see any calypso-specific in the 
header.

+#include <calypso/irq.h>

I got rid of this one.

Regards,

    Wolfram




More information about the baseband-devel mailing list