Linux + u-boot port to MT6235

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at

Marcin Mielczarczyk marcin.mielczarczyk at
Tue Nov 9 05:53:32 UTC 2010

Hi Steve, hi list,

On Mon, Nov 8, 2010 at 3:45 PM, Steve Markgraf <steve at> wrote:
> Hi Marcin, hi list,
> today I received the Sciphone G2 and 'hacked' the headphone cable into a
> serial cable (which worked quite well, compared to the Mobistel).
> osmocon worked on the first try. I only had to modify the UART_BASE address
> in my mtk test code (steve-m/mtk_hack). (log attached)

That's really good. I connected PL2303 to my PC and it also worked
(before I used two built-in ports in Dell computer). I had this kind
of problem some time ago with mini2440 board (based on s3c2440).
I was able to download the code and it started on the phone but hanged
just after printing HW version. I'll check why is that.
Unfortunatelly I had problems pushing my UBoot code to, so until I'll not solve them, you can use my patch
from attachment.
This patch should be applied on recent repository of UBoot:


After applying patch it should be possible to configure Sciphone G2 target:

make sciphone_g2_config

After compilation you should be able to download UBoot to Sciphone
using osmocon.
For this, there should be PLL turned on and then EMI controller
initialized to be able to download UBoot code to external RAM (size of
UBoot is about 120KB). You can find this initialization in
"board/mtk/sciphone_g2/sciphone_g2.c" file. It should be applied to

-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0001-sciphone_g2-Added-support-for-Sciphone-G2.patch
Type: application/octet-stream
Size: 44831 bytes
Desc: not available
URL: <>

More information about the baseband-devel mailing list