Running osmocombb on a Motorol C118

Maciej Grela maciej.grela at
Fri Jul 2 09:52:34 UTC 2010

2010/7/2 Steve Markgraf <steve at>:
> Hi,
> At 01.07.2010 23:37, Maciej Grela wrote:
>> Here are the steps I'm taking:
>> 1. Run osmocom:
>> 2. Press power on the phone.
> Before step 2, start the upper layer application, e.g.
> host/layer23/src/mobile
>> 3. Phone boots and downloads code from osmocon (this code lands in RAM
>> I presume)
> Right, the code is loaded to the internal SRAM of the Calypso DBB.
>> What is the layer1 firmware supposed to do now ? I've tried to run
>> layer23/bcch_scan and layer23/layer23 but they don't print any
>> messages and so does the firmware itself. I'm under the impression
>> that the firmware freezes. Have you tested the firmware on a C118
>> phone ? I will try to find out why it's freezing but maybe I'm missing
>> something obvious ?
> Basically layer23, bcch_scan and mobile wait for the layer1 reset message,
> thus have to be started before powering on the phone.

Thanks, that worked. Now I need to find out why I cannot do FCCH.

Maciej Grela

More information about the baseband-devel mailing list