where are current repo versions of UHD, openBTS and Gnuradio?

Alexander Chemeris alexander.chemeris at gmail.com
Sat Nov 2 10:55:34 UTC 2013


On Sat, Nov 2, 2013 at 2:10 PM, Robert Light <robert.light at gmx.de> wrote:
> Hi, I am aware of Commotion-OpenBTS and I even gave it a try, however for
> some reason it does not detect my usrp1.
> Are there more detailed instructions on how to use it?
> I simply put it on a USB stick with unetbootin, no persistance (adding
> persistance would be nice). When booted it does the configuration
> succesfully, but what to do after that ?
> Commotion-OpenBTS is a great idea, if I could only get it to work.

You could probably ask at the Commotion mailing list. I don't have
much experience with it, unfortunately.

> Alexander, Will GnuRadio 3.6 work with usrp1 and osmoBTS or openBTS?

Any recent GnuRadio version works with UHD driver, which supported USRP1.

Osmocom and OpenBTS require libusrp to work with USRP1, which is not
available in GnuRadio 3.6.

That said, you should be able to install libusrp to a separate
directory specifically to make Osmocom and OpenBTS to work.

> I am also intalling osmobts on another computer, but that is causing me a
> lot of problems. ortp and srtp seem to be conflicting with libosip2-dev and
> libortp-dev from ubuntu and when I install

Interesting. I've never seen any issues with it. We run it on Ubuntu
12.04 without any issues.

> http://download.savannah.gnu.org/releases/linphone/ortp/sources/
> http://sourceforge.net/projects/sofia-sip/files/sofia-sip/
> I get problems compiling OpenBTS and some other software.
> So it looks like OpenBTS and OsmoBTS cannot coexist on one computer. At
> least not on my.

Yeah, osip changed some functions and broke backward compatibility.
IIRC, Osmocom needs to be updated to detect that at configure time to
compile with the latest osip versions. Should be relatively easy to
do.

> Too many versions keep confusing me. i.e. openbts-P2.8.0Opelousas.tar.gz
> from http://sourceforge.net/projects/openbts/files/2.8.0/
> for some reason doesn't understand
> "--with-usrp1 --with-singledb" switches but openbts 2.8 downloaded from
> other sources has no problems with that.

That's an ancient version. Don't use it.

-- 
Regards,
Alexander Chemeris.
CEO, Fairwaves LLC / ООО УмРадио
http://fairwaves.ru




More information about the UmTRX mailing list