Problems compiling rtl-sdr on debian

lee jones slothpuck at gmail.com
Sun Aug 4 22:01:19 UTC 2013


Apologies for continually replying but I also just noticed these
three lines in dmesg as I've been trying all of this out:

[   66.714466] rtl_tcp[3670]: segfault at 0 ip 00007f5d329389f2 sp
00007fff71c8e780 error 6 in libusb-1.0.so.0.1.0[7f5d32930000+15000]
[   87.168292] rtl_tcp[3812]: segfault at 0 ip 00007f0d2fc609f2 sp
00007f0d2e26cb50 error 6 in libusb-1.0.so.0.1.0[7f0d2fc58000+15000]
[  398.814077] rtl_tcp[8760]: segfault at 0 ip 00007f623a1a09f2 sp
00007f62384acb40 error 6 in libusb-1.0.so.0.1.0[7f623a198000+15000]

Maybe this is a case of something not liking libusb at all? BTW here's
some info on the version of libusb I have installed on my system:

# aptitude show libusb-1.0-0
Package: libusb-1.0-0
State: installed
Automatically installed: no
Multi-Arch: same
Version: 2:1.0.16-3
Priority: optional
Section: libs

ljones


On 8/4/13, lee jones <slothpuck at gmail.com> wrote:
> I also have re-tried with installing the pkgconfig file recompiling by
> using autoconf rather than cmake. But I still get lots of errors;
>
> http://slothpuck.no-ip.org/tmp/autoconf-build2.txt
>
> what's concerning me are all those "unused parameter" error messages,
> as if they aren't being built in and that's maybe why rtl_tcp just
> hangs or crashes.
>
> ljones
>
> On 8/4/13, lee jones <slothpuck at gmail.com> wrote:
>> On 8/4/13, lee jones <slothpuck at gmail.com> wrote:
>>>>Look at the following line - it is telling you everything you want to
>>>> know...
>>>>Could NOT find PkgConfig (missing:  PKG_CONFIG_EXECUTABLE)
>>>
>>> Will try that though not sure why on the other method the configure
>>> script wouldn't complete! x.x
>>>
>>
>> Ok I gave that a try. I managed to track down the missing pkgconfig file.
>>
>> The line about not finding pkgconfig has now gone - but all of the
>> errors at compile time are all still there, and rtl_tcp still crashes.
>> Installing pkg-config got rid of the error, but not much else
>> unfortunarly x.x
>>
>> ljones
>>
>
>
> --
> :)
>
> SP
>


-- 
:)

SP




More information about the osmocom-sdr mailing list