Problems compiling rtl-sdr on debian

lee jones slothpuck at gmail.com
Sun Aug 4 21:43:08 UTC 2013


I also have re-tried with installing the pkgconfig file recompiling by
using autoconf rather than cmake. But I still get lots of errors;

http://slothpuck.no-ip.org/tmp/autoconf-build2.txt

what's concerning me are all those "unused parameter" error messages,
as if they aren't being built in and that's maybe why rtl_tcp just
hangs or crashes.

ljones

On 8/4/13, lee jones <slothpuck at gmail.com> wrote:
> On 8/4/13, lee jones <slothpuck at gmail.com> wrote:
>>>Look at the following line - it is telling you everything you want to
>>> know...
>>>Could NOT find PkgConfig (missing:  PKG_CONFIG_EXECUTABLE)
>>
>> Will try that though not sure why on the other method the configure
>> script wouldn't complete! x.x
>>
>
> Ok I gave that a try. I managed to track down the missing pkgconfig file.
>
> The line about not finding pkgconfig has now gone - but all of the
> errors at compile time are all still there, and rtl_tcp still crashes.
> Installing pkg-config got rid of the error, but not much else
> unfortunarly x.x
>
> ljones
>


-- 
:)

SP




More information about the osmocom-sdr mailing list