Data Rate of EGPRS is Too Low

XINKE ZHANG xinke.zhang at hotmail.com
Thu Apr 12 07:43:03 UTC 2018


Hi Matthew,


I'm sorry for late reply.

I have also tested the latest split components running on a xubuntu 14.04 machine, but the throughput is very limited. I buy a test phone, and find that the dl bler is so high. In my opinion, the high dl bler causes the low throughput. Nowadays, I'm trying to locate issues, but there is no progress.


Best Regards,

Xinke

________________________________
From: Matthew Johnson <matt9j at cs.washington.edu>
Sent: Wednesday, April 4, 2018 16:54
To: Neels Hofmeyr
Cc: XINKE ZHANG; osmocom-net-gprs at lists.osmocom.org
Subject: Re: Data Rate of EGPRS is Too Low

Hello Xinke,
I'm a graduate student at the University of Washington, and just brought up an EGPRS/GPRS network with an Ettus B210/osmo-trx. My B210 has a GPSDO as well. I'm just getting started on this project (so I'm unfortunately not the expert you are looking for), but I can corroborate that I am also seeing very limited single user throughput in EGRPS and vanilla GRPS (6-8kbps maximum measured via iperf). My network is built with the latest split components running on a debian9 virtual machine via virtualbox. I'll attach my configs here if they're helpful. I also have access to a litecell1.5 and will be bringing up the network on it in the next few weeks, so I'll be able to report if it behaves any better. The litecell setup will also be running on dedicated hardware to rule out any strangeness from virtualbox. Sorry I don't have any other clues at this time, but I can at least confirm Neels's analysis above and rule out the impact of running the old nitb and ggsn.
Cheers,
-Matt Johnson

On Mon, Mar 5, 2018 at 2:15 PM, Neels Hofmeyr <nhofmeyr at sysmocom.de<mailto:nhofmeyr at sysmocom.de>> wrote:
On Sat, Mar 03, 2018 at 12:18:52PM +0000, XINKE ZHANG wrote:
> I'm sure that B210 has a GPSDO. I execute 'uhd_usrp_probe' to prove it.

I'm not familiar with it, but if you say so.

> My entire config files are attached here. Pls help check it. Thanks.

It all looks good to me. Two minor notes:

- the pcu config once needed 'two-phase-access' to function reliably, but this
  is no longer needed.

- you seem to be running an old version of the ggsn. The new one is called
  osmo-ggsn with a config file style and vty interface like the other osmo
  programs. However, this should not affect your downlink throughput.

- you also seem to run osmo-nitb, we have moved to separate programs, being
  osmo-hlr, osmo-msc and osmo-bsc. Refer to
  http://osmocom.org/projects/cellular-infrastructure/wiki/Osmocom_Network_In_The_Box
  This should, however, not affect your downlink throughput, either.

So yeah, sorry, but I have nothing of weight to add. Maybe someone else here
has deeper knowledge of EGPRS and SDR based BTS?

~N


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/osmocom-net-gprs/attachments/20180412/3a6d9008/attachment.html>


More information about the osmocom-net-gprs mailing list