[osmo-pcu 0.2.896-0a8f] testsuite: 4 failed

Arnaud ZANETTI arnaud.zanetti at free.fr
Fri Mar 24 09:53:53 UTC 2017


Hi,

building osmo-pcu on a raspberry Pi 3, I noticed a failure in make check:

## --------------------------------- ##
## osmo-pcu 0.2.896-0a8f test suite. ##
## --------------------------------- ##

Regression tests

   1: rlcmac                                          ok
   2: ts_alloc                                        ok
   3: tbf                                             ok
   4: bitcomp FAILED (testsuite.at:30)
   5: edge                                            ok
   6: types                                           ok
   7: ms                                              ok
   8: llc                                             ok
   9: llist                                           ok
  10: codel                                           ok
  11: fn                                              ok

## ------------- ##
## Test results. ##
## ------------- ##

ERROR: All 11 tests were run,
1 failed unexpectedly.
## -------------------------- ##
## testsuite.log was created. ##
## -------------------------- ##

The exact same test also fails on a raspberry Pi 2, with the same 
osmo-pcu and gcc versions but succeeds on an old Pentium4

Feel free to contact me if you need further informations.

-----
Arnaud ZANETTI

-------------- next part --------------
A non-text attachment was scrubbed...
Name: testsuite.log
Type: text/x-log
Size: 39149 bytes
Desc: not available
URL: <http://lists.osmocom.org/pipermail/osmocom-net-gprs/attachments/20170324/f9a695a8/attachment-0001.bin>


More information about the osmocom-net-gprs mailing list