[PATCH net-next 0/4] gtp: support multiple APN's per GTP endpoint

Pablo Neira Ayuso pablo at netfilter.org
Tue Mar 14 13:42:16 UTC 2017


On Tue, Mar 14, 2017 at 01:42:44PM +0100, Andreas Schultz wrote:
> > It is definitely not acceptable to break the existing API.
> 
> The specific use case of the API that is no longer supported was never used by
> anyone. [...]

Yes, this was used openggsn and I tested this with a full blown FOSS
setup. Yes, a toy thing compared to the proprietary equipment you deal
with, but we always started with things like this.

> The only supported and documented API for the GTP module is libgtpnl.

No, the netlink interface itself if the API.

Stopping trying to find a reason to break API, that is a no-go.


More information about the osmocom-net-gprs mailing list