"lai_and_lac"

Stefan Sperling ssperling at sysmocom.de
Mon Mar 26 10:54:45 UTC 2018


On Fri, Mar 23, 2018 at 04:33:39PM +0100, Neels Hofmeyr wrote:
> I noticed that the CELL_IDENT enum has a similar quirk:
> CELL_IDENT_LAI_AND_LAC
> so it probably came from that.

Yes, this is where it came from.

> I think we should rename it and have a backwards compat:
>   #define CELL_IDENT_LAI_AND_LAC CELL_IDENT_LAI

The standard from 1999 (TS 08.08 section 3.2.2.27 "Cell Identifier list")
calls it just "LAI":

 "Location Area Identification, LAI, is used to identify all cells
  within a Location Area"

So I would agree with your proposal.


More information about the OpenBSC mailing list