Build failed in Jenkins: Osmocom-repo-install-debian9 » latest,repo-install-test #139

jenkins at lists.osmocom.org jenkins at lists.osmocom.org
Wed Jun 9 10:40:34 UTC 2021


See <https://jenkins.osmocom.org/jenkins/job/Osmocom-repo-install-debian9/feed=latest,label=repo-install-test/139/display/redirect>

Changes:


------------------------------------------
[...truncated 10.37 KB...]
	 -e container=docker --tmpfs /run --tmpfs /run/lock+  --tmpfs /tmp -v /sys/fs/cgroup:/sys/fs/cgroup:ro --cap-add SYS_ADMIN --cap-add SYS_NICEseq osmocom-build/debian9-repo-install-test 1 /lib/systemd/systemd 10

+ sleep 1
+ docker exec debian9-repo-install-test-latest systemctl status
● 764ed2a8bbea
    State: running
     Jobs: 0 queued
   Failed: 0 units
    Since: Wed 2021-06-09 10:40:11 UTC; 373ms ago
   CGroup: /docker/764ed2a8bbea82b597cc533a4ca5801a50e3a28ea7b804d59c77f22c13618848
           ├─26 systemctl status
           ├─init.scope
           │ └─1 /lib/systemd/systemd
           └─system.slice
             └─systemd-journald.service
               └─17 /lib/systemd/systemd-journald
+ return
+ ret=0
+ docker exec debian9-repo-install-test-latest /repo-install-test/run-inside-docker.sh
Checking feed: latest
Checking project: network:osmocom:latest
Checking conflicting project: network:osmocom:nightly
Linux distribution: debian9
Enabled tests: 
		test_conflict
		install_repo_packages
		test_binaries
		services_check
	
+ SERVICES=
	osmo-bsc
	osmo-gbproxy
	osmo-gtphub
	osmo-hlr
	osmo-mgw
	osmo-msc
	osmo-pcap-client
	osmo-sip-connector
	osmo-stp

+ SERVICES_NIGHTLY=
	osmo-pcap-server
	osmo-sgsn
	osmo-pcu
	osmo-hnbgw
	osmo-bts-virtual

+ distro_obsdir
+ echo Debian_9.0
+ DISTRO_OBSDIR=Debian_9.0
+ check_env
+ [ -n latest ]
+ echo Checking feed: latest
+ [ -n network:osmocom:latest ]
+ echo Checking project: network:osmocom:latest
+ [ -n network:osmocom:nightly ]
+ echo Checking conflicting project: network:osmocom:nightly
+ [ -n debian9 ]
+ echo Linux distribution: debian9
+ [ -n 
		test_conflict
		install_repo_packages
		test_binaries
		services_check
	 ]
+ echo Enabled tests: 
		test_conflict
		install_repo_packages
		test_binaries
		services_check
	
+ configure_keep_cache
+ [ -z  ]
+ return
+ configure_osmocom_repo network:osmocom:latest
+ configure_osmocom_repo_debian network:osmocom:latest
+ local proj=network:osmocom:latest
+ proj_with_slashes network:osmocom:latest
+ echo network:osmocom:latest
+ sed s.:.:/.g
+ local obs_repo=download.opensuse.org/repositories/network:/osmocom:/latest/Debian_9.0/
+ local release_key=/var/cache/apt/network:osmocom:latest_Release.key
+ echo Configuring Osmocom repository
+ [ -e /var/cache/apt/network:osmocom:latest_Release.key ]Configuring Osmocom repository

+ apt-get update
Ign:1 http://deb.debian.org/debian stretch InRelease
Get:2 http://deb.debian.org/debian stretch-updates InRelease [93.6 kB]
Get:3 http://security.debian.org/debian-security stretch/updates InRelease [53.0 kB]
Hit:4 http://deb.debian.org/debian stretch Release
Get:5 http://security.debian.org/debian-security stretch/updates/main amd64 Packages [691 kB]
Fetched 837 kB in 0s (2017 kB/s)
Reading package lists...
+ apt install -y wget

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

Reading package lists...
Building dependency tree...
Reading state information...
The following additional packages will be installed:
  ca-certificates libffi6 libgmp10 libgnutls30 libhogweed4 libidn2-0
  libp11-kit0 libpsl5 libssl1.1 libtasn1-6 libunistring0 openssl publicsuffix
Suggested packages:
  gnutls-bin
The following NEW packages will be installed:
  ca-certificates libffi6 libgmp10 libgnutls30 libhogweed4 libidn2-0
  libp11-kit0 libpsl5 libssl1.1 libtasn1-6 libunistring0 openssl publicsuffix
  wget
0 upgraded, 14 newly installed, 0 to remove and 1 not upgraded.
Need to get 5034 kB of archives.
After this operation, 13.9 MB of additional disk space will be used.
Get:1 http://deb.debian.org/debian stretch/main amd64 libgmp10 amd64 2:6.1.2+dfsg-1 [253 kB]
Get:2 http://security.debian.org/debian-security stretch/updates/main amd64 libssl1.1 amd64 1.1.0l-1~deb9u3 [1359 kB]
Get:3 http://deb.debian.org/debian stretch/main amd64 libhogweed4 amd64 3.3-1+b2 [136 kB]
Get:4 http://deb.debian.org/debian stretch/main amd64 libffi6 amd64 3.2.1-6 [20.4 kB]
Get:5 http://deb.debian.org/debian stretch/main amd64 libtasn1-6 amd64 4.10-1.1+deb9u1 [50.6 kB]
Get:6 http://deb.debian.org/debian stretch/main amd64 libgnutls30 amd64 3.5.8-5+deb9u5 [896 kB]
Get:7 http://deb.debian.org/debian stretch/main amd64 libunistring0 amd64 0.9.6+really0.9.3-0.1 [279 kB]
Get:8 http://deb.debian.org/debian stretch/main amd64 libidn2-0 amd64 0.16-1+deb9u1 [60.7 kB]
Get:9 http://deb.debian.org/debian stretch/main amd64 libpsl5 amd64 0.17.0-3 [41.8 kB]
Get:10 http://deb.debian.org/debian stretch/main amd64 wget amd64 1.18-5+deb9u3 [800 kB]
Get:11 http://deb.debian.org/debian stretch/main amd64 publicsuffix all 20190415.1030-0+deb9u1 [108 kB]
Get:12 http://security.debian.org/debian-security stretch/updates/main amd64 libp11-kit0 amd64 0.23.3-2+deb9u1 [112 kB]
Get:13 http://security.debian.org/debian-security stretch/updates/main amd64 openssl amd64 1.1.0l-1~deb9u3 [749 kB]
Get:14 http://security.debian.org/debian-security stretch/updates/main amd64 ca-certificates all 20200601~deb9u2 [168 kB]
debconf: delaying package configuration, since apt-utils is not installed
Fetched 5034 kB in 0s (20.7 MB/s)
Selecting previously unselected package libssl1.1:amd64.
(Reading database ... (Reading database ... 5%(Reading database ... 10%(Reading database ... 15%(Reading database ... 20%(Reading database ... 25%(Reading database ... 30%(Reading database ... 35%(Reading database ... 40%(Reading database ... 45%(Reading database ... 50%(Reading database ... 55%(Reading database ... 60%(Reading database ... 65%(Reading database ... 70%(Reading database ... 75%(Reading database ... 80%(Reading database ... 85%(Reading database ... 90%(Reading database ... 95%(Reading database ... 100%(Reading database ... 7704 files and directories currently installed.)
Preparing to unpack .../00-libssl1.1_1.1.0l-1~deb9u3_amd64.deb ...
Unpacking libssl1.1:amd64 (1.1.0l-1~deb9u3) ...
Selecting previously unselected package libgmp10:amd64.
Preparing to unpack .../01-libgmp10_2%3a6.1.2+dfsg-1_amd64.deb ...
Unpacking libgmp10:amd64 (2:6.1.2+dfsg-1) ...
Selecting previously unselected package libhogweed4:amd64.
Preparing to unpack .../02-libhogweed4_3.3-1+b2_amd64.deb ...
Unpacking libhogweed4:amd64 (3.3-1+b2) ...
Selecting previously unselected package libffi6:amd64.
Preparing to unpack .../03-libffi6_3.2.1-6_amd64.deb ...
Unpacking libffi6:amd64 (3.2.1-6) ...
Selecting previously unselected package libp11-kit0:amd64.
Preparing to unpack .../04-libp11-kit0_0.23.3-2+deb9u1_amd64.deb ...
Unpacking libp11-kit0:amd64 (0.23.3-2+deb9u1) ...
Selecting previously unselected package libtasn1-6:amd64.
Preparing to unpack .../05-libtasn1-6_4.10-1.1+deb9u1_amd64.deb ...
Unpacking libtasn1-6:amd64 (4.10-1.1+deb9u1) ...
Selecting previously unselected package libgnutls30:amd64.
Preparing to unpack .../06-libgnutls30_3.5.8-5+deb9u5_amd64.deb ...
Unpacking libgnutls30:amd64 (3.5.8-5+deb9u5) ...
Selecting previously unselected package libunistring0:amd64.
Preparing to unpack .../07-libunistring0_0.9.6+really0.9.3-0.1_amd64.deb ...
Unpacking libunistring0:amd64 (0.9.6+really0.9.3-0.1) ...
Selecting previously unselected package libidn2-0:amd64.
Preparing to unpack .../08-libidn2-0_0.16-1+deb9u1_amd64.deb ...
Unpacking libidn2-0:amd64 (0.16-1+deb9u1) ...
Selecting previously unselected package libpsl5:amd64.
Preparing to unpack .../09-libpsl5_0.17.0-3_amd64.deb ...
Unpacking libpsl5:amd64 (0.17.0-3) ...
Selecting previously unselected package wget.
Preparing to unpack .../10-wget_1.18-5+deb9u3_amd64.deb ...
Unpacking wget (1.18-5+deb9u3) ...
Selecting previously unselected package openssl.
Preparing to unpack .../11-openssl_1.1.0l-1~deb9u3_amd64.deb ...
Unpacking openssl (1.1.0l-1~deb9u3) ...
Selecting previously unselected package ca-certificates.
Preparing to unpack .../12-ca-certificates_20200601~deb9u2_all.deb ...
Unpacking ca-certificates (20200601~deb9u2) ...
Selecting previously unselected package publicsuffix.
Preparing to unpack .../13-publicsuffix_20190415.1030-0+deb9u1_all.deb ...
Unpacking publicsuffix (20190415.1030-0+deb9u1) ...
Setting up libtasn1-6:amd64 (4.10-1.1+deb9u1) ...
Setting up libgmp10:amd64 (2:6.1.2+dfsg-1) ...
Processing triggers for libc-bin (2.24-11+deb9u4) ...
Setting up publicsuffix (20190415.1030-0+deb9u1) ...
Setting up libunistring0:amd64 (0.9.6+really0.9.3-0.1) ...
Setting up libssl1.1:amd64 (1.1.0l-1~deb9u3) ...
debconf: unable to initialize frontend: Dialog
debconf: (TERM is not set, so the dialog frontend is not usable.)
debconf: falling back to frontend: Readline
debconf: unable to initialize frontend: Readline
debconf: (Can't locate Term/ReadLine.pm in @INC (you may need to install the Term::ReadLine module) (@INC contains: /etc/perl /usr/local/lib/x86_64-linux-gnu/perl/5.24.1 /usr/local/share/perl/5.24.1 /usr/lib/x86_64-linux-gnu/perl5/5.24 /usr/share/perl5 /usr/lib/x86_64-linux-gnu/perl/5.24 /usr/share/perl/5.24 /usr/local/lib/site_perl /usr/lib/x86_64-linux-gnu/perl-base .) at /usr/share/perl5/Debconf/FrontEnd/Readline.pm line 7.)
debconf: falling back to frontend: Teletype
Setting up openssl (1.1.0l-1~deb9u3) ...
Setting up libffi6:amd64 (3.2.1-6) ...
Setting up ca-certificates (20200601~deb9u2) ...
debconf: unable to initialize frontend: Dialog
debconf: (TERM is not set, so the dialog frontend is not usable.)
debconf: falling back to frontend: Readline
debconf: unable to initialize frontend: Readline
debconf: (Can't locate Term/ReadLine.pm in @INC (you may need to install the Term::ReadLine module) (@INC contains: /etc/perl /usr/local/lib/x86_64-linux-gnu/perl/5.24.1 /usr/local/share/perl/5.24.1 /usr/lib/x86_64-linux-gnu/perl5/5.24 /usr/share/perl5 /usr/lib/x86_64-linux-gnu/perl/5.24 /usr/share/perl/5.24 /usr/local/lib/site_perl /usr/lib/x86_64-linux-gnu/perl-base .) at /usr/share/perl5/Debconf/FrontEnd/Readline.pm line 7.)
debconf: falling back to frontend: Teletype
Updating certificates in /etc/ssl/certs...
137 added, 0 removed; done.
Setting up libidn2-0:amd64 (0.16-1+deb9u1) ...
Setting up libpsl5:amd64 (0.17.0-3) ...
Setting up libhogweed4:amd64 (3.3-1+b2) ...
Setting up libp11-kit0:amd64 (0.23.3-2+deb9u1) ...
Setting up libgnutls30:amd64 (3.5.8-5+deb9u5) ...
Setting up wget (1.18-5+deb9u3) ...
Processing triggers for libc-bin (2.24-11+deb9u4) ...
Processing triggers for ca-certificates (20200601~deb9u2) ...
Updating certificates in /etc/ssl/certs...
0 added, 0 removed; done.
Running hooks in /etc/ca-certificates/update.d...
done.
+ wget -O /var/cache/apt/network:osmocom:latest_Release.key https://download.opensuse.org/repositories/network:/osmocom:/latest/Debian_9.0//Release.key
--2021-06-09 10:40:18--  https://download.opensuse.org/repositories/network:/osmocom:/latest/Debian_9.0//Release.key
Resolving download.opensuse.org (download.opensuse.org)... 195.135.221.140, 2001:67c:2178:8::16
Connecting to download.opensuse.org (download.opensuse.org)|195.135.221.140|:443... connected.
HTTP request sent, awaiting response... 302 Found
Location: /download/repositories/network:/osmocom:/latest/Debian_9.0//Release.key [following]
--2021-06-09 10:40:21--  https://download.opensuse.org/download/repositories/network:/osmocom:/latest/Debian_9.0//Release.key
Reusing existing connection to download.opensuse.org:443.
HTTP request sent, awaiting response... 302 Found
Location: https://mirrorcache-eu.opensuse.org/download/repositories/network:/osmocom:/latest/Debian_9.0//Release.key [following]
--2021-06-09 10:40:27--  https://mirrorcache-eu.opensuse.org/download/repositories/network:/osmocom:/latest/Debian_9.0//Release.key
Resolving mirrorcache-eu.opensuse.org (mirrorcache-eu.opensuse.org)... 195.135.221.140, 2001:67c:2178:8::16
Connecting to mirrorcache-eu.opensuse.org (mirrorcache-eu.opensuse.org)|195.135.221.140|:443... connected.
HTTP request sent, awaiting response... 302 Found
Location: https://ftp.gwdg.de/pub/opensuse/repositories/network:/osmocom:/latest/Debian_9.0/Release.key [following]
--2021-06-09 10:40:31--  https://ftp.gwdg.de/pub/opensuse/repositories/network:/osmocom:/latest/Debian_9.0/Release.key
Resolving ftp.gwdg.de (ftp.gwdg.de)... 134.76.12.6, 2001:638:60f:110::1:2
Connecting to ftp.gwdg.de (ftp.gwdg.de)|134.76.12.6|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1080 (1.1K) [application/octet-stream]
Saving to: '/var/cache/apt/network:osmocom:latest_Release.key'

     0K .                                                     100% 26.9M=0s

2021-06-09 10:40:31 (26.9 MB/s) - '/var/cache/apt/network:osmocom:latest_Release.key' saved [1080/1080]

+ apt-key add /var/cache/apt/network:osmocom:latest_Release.key
Warning: apt-key output should not be parsed (stdout is not a terminal)
OK
+ echo deb http://download.opensuse.org/repositories/network:/osmocom:/latest/Debian_9.0/ ./
+ apt-get update
Ign:2 http://deb.debian.org/debian stretch InRelease
Hit:3 http://deb.debian.org/debian stretch-updates InRelease
Hit:4 http://deb.debian.org/debian stretch Release
Hit:5 http://security.debian.org/debian-security stretch/updates InRelease
Reading package lists...
E: The method driver /usr/lib/apt/methods/https could not be found.
+ ret=1
+ [ -n  ]
+ docker container kill debian9-repo-install-test-latest
debian9-repo-install-test-latest
+ exit 1
Build step 'Execute shell' marked build as failure


More information about the jenkins-notifications mailing list