Build failed in Jenkins: Osmocom-repo-install-debian » nightly,build2-deb9build-ansible #248

jenkins at lists.osmocom.org jenkins at lists.osmocom.org
Thu Jan 21 04:11:26 UTC 2021


See <https://jenkins.osmocom.org/jenkins/job/Osmocom-repo-install-debian/feed=nightly,label=build2-deb9build-ansible/248/display/redirect?page=changes>

Changes:

[Oliver Smith] repo-install-test: tweak FEED syntax

[Oliver Smith] repo-install-test: add PROJ variable

[Oliver Smith] repo-install-test: make HTTP, OBS vars local

[Oliver Smith] repo-install-test: put $PROJ in sources.list name

[Oliver Smith] repo-install-test: don't use $FEED in centos8 repo

[Oliver Smith] repo-install-test: download/add deb release key

[Oliver Smith] repo-install-test: cfg_osmocom_repo: add PROJ arg

[Oliver Smith] repo-install-test: add TESTS variable

[Oliver Smith] repo-install-test: add test_conflict


------------------------------------------
[...truncated 23.76 KB...]
Preparing to unpack .../00-osmocom-nightly_1.0.0.202101200126_amd64.deb ...
Unpacking osmocom-nightly (1.0.0.202101200126) ...
Selecting previously unselected package libsctp1:amd64.
Preparing to unpack .../01-libsctp1_1.0.17+dfsg-1+b1_amd64.deb ...
Unpacking libsctp1:amd64 (1.0.17+dfsg-1+b1) ...
Selecting previously unselected package libtalloc2:amd64.
Preparing to unpack .../02-libtalloc2_2.1.8-1_amd64.deb ...
Unpacking libtalloc2:amd64 (2.1.8-1) ...
Selecting previously unselected package libosmocore16:amd64.
Preparing to unpack .../03-libosmocore16_1.4.0.380.fd96_amd64.deb ...
Unpacking libosmocore16:amd64 (1.4.0.380.fd96) ...
Selecting previously unselected package libosmocodec0:amd64.
Preparing to unpack .../04-libosmocodec0_1.4.0.380.fd96_amd64.deb ...
Unpacking libosmocodec0:amd64 (1.4.0.380.fd96) ...
Selecting previously unselected package libosmogsm15:amd64.
Preparing to unpack .../05-libosmogsm15_1.4.0.380.fd96_amd64.deb ...
Unpacking libosmogsm15:amd64 (1.4.0.380.fd96) ...
Selecting previously unselected package libosmocoding0:amd64.
Preparing to unpack .../06-libosmocoding0_1.4.0.380.fd96_amd64.deb ...
Unpacking libosmocoding0:amd64 (1.4.0.380.fd96) ...
Selecting previously unselected package libosmovty4:amd64.
Preparing to unpack .../07-libosmovty4_1.4.0.380.fd96_amd64.deb ...
Unpacking libosmovty4:amd64 (1.4.0.380.fd96) ...
Selecting previously unselected package libosmogb11:amd64.
Preparing to unpack .../08-libosmogb11_1.4.0.380.fd96_amd64.deb ...
Unpacking libosmogb11:amd64 (1.4.0.380.fd96) ...
Selecting previously unselected package libosmoctrl0:amd64.
Preparing to unpack .../09-libosmoctrl0_1.4.0.380.fd96_amd64.deb ...
Unpacking libosmoctrl0:amd64 (1.4.0.380.fd96) ...
Selecting previously unselected package libpcsclite1:amd64.
Preparing to unpack .../10-libpcsclite1_1.8.20-1_amd64.deb ...
Unpacking libpcsclite1:amd64 (1.8.20-1) ...
Selecting previously unselected package libosmosim2:amd64.
Preparing to unpack .../11-libosmosim2_1.4.0.380.fd96_amd64.deb ...
Unpacking libosmosim2:amd64 (1.4.0.380.fd96) ...
Selecting previously unselected package libusb-1.0-0:amd64.
Preparing to unpack .../12-libusb-1.0-0_2%3a1.0.21-1_amd64.deb ...
Unpacking libusb-1.0-0:amd64 (2:1.0.21-1) ...
Selecting previously unselected package libosmousb0:amd64.
Preparing to unpack .../13-libosmousb0_1.4.0.380.fd96_amd64.deb ...
Unpacking libosmousb0:amd64 (1.4.0.380.fd96) ...
Selecting previously unselected package libosmocore.
Preparing to unpack .../14-libosmocore_1.4.0.380.fd96_amd64.deb ...
Unpacking libosmocore (1.4.0.380.fd96) ...
Setting up libsctp1:amd64 (1.0.17+dfsg-1+b1) ...
Setting up libpcsclite1:amd64 (1.8.20-1) ...
Setting up osmocom-nightly (1.0.0.202101200126) ...
Setting up libusb-1.0-0:amd64 (2:1.0.21-1) ...
Processing triggers for libc-bin (2.24-11+deb9u4) ...
Setting up libtalloc2:amd64 (2.1.8-1) ...
Setting up libosmocore16:amd64 (1.4.0.380.fd96) ...
Setting up libosmousb0:amd64 (1.4.0.380.fd96) ...
Setting up libosmocodec0:amd64 (1.4.0.380.fd96) ...
Setting up libosmovty4:amd64 (1.4.0.380.fd96) ...
Setting up libosmogsm15:amd64 (1.4.0.380.fd96) ...
Setting up libosmoctrl0:amd64 (1.4.0.380.fd96) ...
Setting up libosmosim2:amd64 (1.4.0.380.fd96) ...
Setting up libosmogb11:amd64 (1.4.0.380.fd96) ...
Setting up libosmocoding0:amd64 (1.4.0.380.fd96) ...
Setting up libosmocore (1.4.0.380.fd96) ...
Processing triggers for libc-bin (2.24-11+deb9u4) ...
+ configure_osmocom_repo_debian_remove network:osmocom:nightly
+ local proj=network:osmocom:nightly
+ rm /etc/apt/sources.list.d/network:osmocom:nightly.list
+ configure_osmocom_repo_debian network:osmocom:latest
+ local proj=network:osmocom:latest
+ proj_with_slashes network:osmocom:latest
+ echo network:osmocom:latest
+ sed s.:.:/.g
+ local obs_repo=download.opensuse.org/repositories/network:/osmocom:/latest/Debian_9.0/
+ local release_key=/var/cache/apt/network:osmocom:latest_Release.key
+ echo Configuring Osmocom repository
Configuring Osmocom repository
+ echo deb http://download.opensuse.org/repositories/network:/osmocom:/latest/Debian_9.0/ ./
+ [ -e /var/cache/apt/network:osmocom:latest_Release.key ]
+ apt install -y wget

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

Reading package lists...
Building dependency tree...
Reading state information...
wget is already the newest version (1.18-5+deb9u3).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
+ wget -O /var/cache/apt/network:osmocom:latest_Release.key https://download.opensuse.org/repositories/network:/osmocom:/latest/Debian_9.0//Release.key
--2021-01-21 04:11:21--  https://download.opensuse.org/repositories/network:/osmocom:/latest/Debian_9.0//Release.key
Resolving download.opensuse.org (download.opensuse.org)... 195.135.221.134, 2001:67c:2178:8::13
Connecting to download.opensuse.org (download.opensuse.org)|195.135.221.134|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1080 (1.1K)
Saving to: '/var/cache/apt/network:osmocom:latest_Release.key'

     0K .                                                     100% 19.6M=0s

2021-01-21 04:11:21 (19.6 MB/s) - '/var/cache/apt/network:osmocom:latest_Release.key' saved [1080/1080]

+ apt-key add /var/cache/apt/network:osmocom:latest_Release.key
Warning: apt-key output should not be parsed (stdout is not a terminal)
OK
+ apt-get update
Get:1 http://download.opensuse.org/repositories/network:/osmocom:/latest/Debian_9.0 ./ InRelease [1608 B]
Ign:2 http://deb.debian.org/debian stretch InRelease
Hit:3 http://deb.debian.org/debian stretch-updates InRelease
Hit:4 http://security.debian.org/debian-security stretch/updates InRelease
Hit:5 http://deb.debian.org/debian stretch Release
Get:7 http://download.opensuse.org/repositories/network:/osmocom:/latest/Debian_9.0 ./ Packages [96.6 kB]
Fetched 98.2 kB in 0s (253 kB/s)
Reading package lists...
+ apt-get -y install osmo-mgw
+ tee /tmp/out
Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 osmo-mgw : Depends: osmocom-latest but it is not going to be installed
            Depends: libosmonetif8 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
+ [ -e /tmp/fail ]
+ find_patterns_or_exit /tmp/out requested an impossible situation ^The following packages have unmet dependencies: Depends: osmocom- but it is not going to be installed
+ local file=/tmp/out
+ local pattern
+ shift
+ grep -q requested an impossible situation /tmp/out
+ continue
+ grep -q ^The following packages have unmet dependencies: /tmp/out
+ continue
+ grep -q Depends: osmocom- /tmp/out
+ continue
+ grep -q but it is not going to be installed /tmp/out
+ continue
+ configure_osmocom_repo_debian_remove network:osmocom:latest
+ local proj=network:osmocom:latest
+ rm /etc/apt/sources.list.d/network:osmocom:latest.list
+ configure_osmocom_repo_debian network:osmocom:nightly
+ local proj=network:osmocom:nightly
+ proj_with_slashes network:osmocom:nightly
+ echo network:osmocom:nightly
+ sed s.:.:/.g
+ local obs_repo=download.opensuse.org/repositories/network:/osmocom:/nightly/Debian_9.0/
+ local release_key=/var/cache/apt/network:osmocom:nightly_Release.key
+ echo Configuring Osmocom repository
Configuring Osmocom repository
+ echo deb http://download.opensuse.org/repositories/network:/osmocom:/nightly/Debian_9.0/ ./
+ [ -e /var/cache/apt/network:osmocom:nightly_Release.key ]
+ apt-key add /var/cache/apt/network:osmocom:nightly_Release.key
Warning: apt-key output should not be parsed (stdout is not a terminal)
OK
+ apt-get update
Get:1 http://download.opensuse.org/repositories/network:/osmocom:/nightly/Debian_9.0 ./ InRelease [1593 B]
Ign:2 http://deb.debian.org/debian stretch InRelease
Hit:3 http://deb.debian.org/debian stretch-updates InRelease
Hit:4 http://security.debian.org/debian-security stretch/updates InRelease
Hit:5 http://deb.debian.org/debian stretch Release
Get:6 http://download.opensuse.org/repositories/network:/osmocom:/nightly/Debian_9.0 ./ Packages [117 kB]
Fetched 119 kB in 0s (342 kB/s)
Reading package lists...

### Running test: install_repo_packages ###

Installing all repository packages
+ set +x
+ install_repo_packages_debian
+ local obs=obs://build.opensuse.org/network:osmocom:nightly/Debian_9.0
+ echo Installing all repository packages
+ aptitude search -F%p ?origin(obs://build.opensuse.org/network:osmocom:nightly/Debian_9.0) ?architecture(native)
+ sort
+ filter_packages_txt
+ grep -v ^# /repo-install-test/blacklist_debian.txt
+ sort -u
+ comm -23 osmocom_packages_all.txt blacklist.txt
+ cat osmocom_packages.txt
+ apt install -y abisip-find binutils-arm-osmo-eabi binutils-arm-osmo-eabi-dbgsym libasn1c-dbg libasn1c-dev libasn1c1 libgtp-dbg libgtp-dev libgtp6 libgtpnl-dbg libgtpnl-dev libgtpnl0 libifd-osmo-remsim-client0 libifd-osmo-remsim-client0-dbgsym liblimesuite-dev liblimesuite20.10-1 liblimesuite20.10-1-dbgsym liborcania-dev liborcania1.2 liborcania1.2-dbgsym libosmo-abis libosmo-abis-dbg libosmo-abis-dev libosmo-e1d-dev libosmo-e1d0 libosmo-e1d0-dbgsym libosmo-fl2k-dev libosmo-fl2k0 libosmo-fl2k0-dbgsym libosmo-gsup-client-dev libosmo-gsup-client0 libosmo-mgcp-client-dev libosmo-mgcp-client6 libosmo-mgcp-client6-dbgsym libosmo-mslookup-dev libosmo-mslookup0 libosmo-netif-dbg libosmo-netif-dev libosmo-netif-doc libosmo-ranap-dbg libosmo-ranap-dev libosmo-ranap3 libosmo-rspro-dev libosmo-rspro1 libosmo-rspro1-dbgsym libosmo-sabp-dbg libosmo-sabp-dev libosmo-sabp0 libosmo-sccp-dev libosmo-sigtran-dbg libosmo-sigtran-dev libosmo-sigtran-doc libosmo-sigtran5 libosmo-simtrace2-0 libosmo-simtrace2-0-dbgsym libosmo-simtrace2-dev libosmoabis9 libosmocodec-doc libosmocodec0 libosmocoding-doc libosmocoding0 libosmocore libosmocore-dbg libosmocore-dev libosmocore-doc libosmocore-utils libosmocore16 libosmoctrl-doc libosmoctrl0 libosmodsp-dbg libosmodsp-dev libosmodsp-doc libosmodsp0 libosmogb-doc libosmogb11 libosmogsm-doc libosmogsm15 libosmonetif8 libosmosim2 libosmotrau2 libosmousb0 libosmovty-doc libosmovty4 librtlsdr-dev librtlsdr0 librtlsdr0-dbgsym libsmpp1 libsmpp34-dbg libsmpp34-dev libsmpp34-utils libulfius-dev libulfius2.5 libulfius2.5-dbgsym libusrp-dev libusrp-doc libusrp-firmware libusrp-utils libusrp-utils-dbgsym libusrp1 libusrp1-dbgsym libyder-dev libyder2.0 libyder2.0-dbgsym limesuite limesuite-dbgsym limesuite-images limesuite-images20.10 limesuite-udev neocon neocon-dbgsym osmo-bsc osmo-bsc-bs11-utils osmo-bsc-dbg osmo-bsc-doc osmo-bsc-ipaccess-utils osmo-bsc-meas-utils osmo-bts-doc osmo-bts-trx osmo-bts-trx-dbg osmo-bts-virtual osmo-bts-virtual-dbg osmo-cbc osmo-cbc-dbg osmo-cbc-doc osmo-e1d osmo-e1d-dbgsym osmo-fl2k osmo-fl2k-dbgsym osmo-gbproxy osmo-gbproxy-dbg osmo-ggsn osmo-ggsn-dbg osmo-ggsn-doc osmo-gsm-manuals-dev osmo-gtphub osmo-gtphub-dbg osmo-hlr osmo-hlr-dbg osmo-hlr-doc osmo-hnbgw osmo-hnbgw-dbg osmo-hnbgw-doc osmo-mgw osmo-mgw-dbgsym osmo-mgw-doc osmo-msc osmo-msc-dbg osmo-msc-doc osmo-pcap-client osmo-pcap-client-dbg osmo-pcap-server osmo-pcap-server-dbg osmo-pcu osmo-pcu-dbg osmo-pcu-doc osmo-remsim-bankd osmo-remsim-bankd-dbgsym osmo-remsim-client-shell osmo-remsim-client-shell-dbgsym osmo-remsim-client-st2 osmo-remsim-client-st2-dbgsym osmo-remsim-doc osmo-remsim-server osmo-remsim-server-dbgsym osmo-sgsn osmo-sgsn-dbg osmo-sgsn-doc osmo-sip-connector osmo-sip-connector-dbg osmo-sip-connector-doc osmo-smlc osmo-smlc-dbg osmo-smlc-doc osmo-stp osmo-stp-dbg osmo-stp-doc osmo-sysmon osmo-sysmon-dbg osmo-trx osmo-trx-dbg osmo-trx-doc osmo-trx-ipc osmo-trx-lms osmo-trx-uhd osmo-trx-usrp1 osmo-uecups osmo-uecups-dbgsym osmocom-nightly python3-osmopy-libs python3-osmopy-utils rtl-sdr rtl-sdr-dbgsym simtrace2-firmware simtrace2-utils simtrace2-utils-dbgsym

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

Reading package lists...
Building dependency tree...
Reading state information...
libosmocodec0 is already the newest version (1.4.0.380.fd96).
libosmocodec0 set to manually installed.
libosmocoding0 is already the newest version (1.4.0.380.fd96).
libosmocoding0 set to manually installed.
libosmocore is already the newest version (1.4.0.380.fd96).
libosmocore16 is already the newest version (1.4.0.380.fd96).
libosmocore16 set to manually installed.
libosmoctrl0 is already the newest version (1.4.0.380.fd96).
libosmoctrl0 set to manually installed.
libosmogb11 is already the newest version (1.4.0.380.fd96).
libosmogb11 set to manually installed.
libosmogsm15 is already the newest version (1.4.0.380.fd96).
libosmogsm15 set to manually installed.
libosmosim2 is already the newest version (1.4.0.380.fd96).
libosmosim2 set to manually installed.
libosmousb0 is already the newest version (1.4.0.380.fd96).
libosmousb0 set to manually installed.
libosmovty4 is already the newest version (1.4.0.380.fd96).
libosmovty4 set to manually installed.
osmocom-nightly is already the newest version (1.0.0.202101200126).
osmocom-nightly set to manually installed.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libosmo-netif-doc : Depends: osmocom-nightly (= 1.0.0.202101210126) but 1.0.0.202101200126 is to be installed
 libosmo-sigtran-doc : Depends: osmocom-nightly (= 1.0.0.202101210126) but 1.0.0.202101200126 is to be installed
 libosmocodec-doc : Depends: osmocom-nightly (= 1.0.0.202101210126) but 1.0.0.202101200126 is to be installed
 libosmocoding-doc : Depends: osmocom-nightly (= 1.0.0.202101210126) but 1.0.0.202101200126 is to be installed
 libosmocore-doc : Depends: osmocom-nightly (= 1.0.0.202101210126) but 1.0.0.202101200126 is to be installed
 libosmoctrl-doc : Depends: osmocom-nightly (= 1.0.0.202101210126) but 1.0.0.202101200126 is to be installed
 libosmodsp-doc : Depends: osmocom-nightly (= 1.0.0.202101210126) but 1.0.0.202101200126 is to be installed
 libosmogb-doc : Depends: osmocom-nightly (= 1.0.0.202101210126) but 1.0.0.202101200126 is to be installed
 libosmogsm-doc : Depends: osmocom-nightly (= 1.0.0.202101210126) but 1.0.0.202101200126 is to be installed
 libosmovty-doc : Depends: osmocom-nightly (= 1.0.0.202101210126) but 1.0.0.202101200126 is to be installed
 libusrp-doc : Depends: osmocom-nightly (= 1.0.0.202101210126) but 1.0.0.202101200126 is to be installed
 osmo-bsc-doc : Depends: osmocom-nightly (= 1.0.0.202101210126) but 1.0.0.202101200126 is to be installed
 osmo-bts-doc : Depends: osmocom-nightly (= 1.0.0.202101210126) but 1.0.0.202101200126 is to be installed
 osmo-cbc-doc : Depends: osmocom-nightly (= 1.0.0.202101210126) but 1.0.0.202101200126 is to be installed
 osmo-ggsn-doc : Depends: osmocom-nightly (= 1.0.0.202101210126) but 1.0.0.202101200126 is to be installed
 osmo-gsm-manuals-dev : Depends: osmocom-nightly (= 1.0.0.202101210126) but 1.0.0.202101200126 is to be installed
 osmo-hlr-doc : Depends: osmocom-nightly (= 1.0.0.202101210126) but 1.0.0.202101200126 is to be installed
 osmo-hnbgw-doc : Depends: osmocom-nightly (= 1.0.0.202101210126) but 1.0.0.202101200126 is to be installed
 osmo-mgw-doc : Depends: osmocom-nightly (= 1.0.0.202101210126) but 1.0.0.202101200126 is to be installed
 osmo-msc-doc : Depends: osmocom-nightly (= 1.0.0.202101210126) but 1.0.0.202101200126 is to be installed
 osmo-pcu-doc : Depends: osmocom-nightly (= 1.0.0.202101210126) but 1.0.0.202101200126 is to be installed
 osmo-remsim-doc : Depends: osmocom-nightly (= 1.0.0.202101210126) but 1.0.0.202101200126 is to be installed
 osmo-sgsn-doc : Depends: osmocom-nightly (= 1.0.0.202101210126) but 1.0.0.202101200126 is to be installed
 osmo-sip-connector-doc : Depends: osmocom-nightly (= 1.0.0.202101210126) but 1.0.0.202101200126 is to be installed
 osmo-smlc-doc : Depends: osmocom-nightly (= 1.0.0.202101210126) but 1.0.0.202101200126 is to be installed
 osmo-stp-doc : Depends: osmocom-nightly (= 1.0.0.202101210126) but 1.0.0.202101200126 is to be installed
 osmo-trx : Depends: osmocom-nightly (= 1.0.0.202101210126) but 1.0.0.202101200126 is to be installed
 osmo-trx-doc : Depends: osmocom-nightly (= 1.0.0.202101210126) but 1.0.0.202101200126 is to be installed
 python3-osmopy-libs : Depends: osmocom-nightly (= 1.0.0.202101210126) but 1.0.0.202101200126 is to be installed
 python3-osmopy-utils : Depends: osmocom-nightly (= 1.0.0.202101210126) but 1.0.0.202101200126 is to be installed
E: Unable to correct problems, you have held broken packages.
+ ret=1
+ [ -n  ]
+ docker container kill debian-repo-install-test-nightly
debian-repo-install-test-nightly
+ exit 1
Build step 'Execute shell' marked build as failure


More information about the jenkins-notifications mailing list