Change in osmo-pcu[master]: Move EGPRS WS computation to C code

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/gerrit-log@lists.osmocom.org/.

Neels Hofmeyr gerrit-no-reply at lists.osmocom.org
Mon Nov 5 03:50:57 UTC 2018


Neels Hofmeyr has posted comments on this change. ( https://gerrit.osmocom.org/6241 )

Change subject: Move EGPRS WS computation to C code
......................................................................


Patch Set 4: Code-Review-1

(2 comments)

https://gerrit.osmocom.org/#/c/6241/4/src/mslot_class.c
File src/mslot_class.c:

https://gerrit.osmocom.org/#/c/6241/4/src/mslot_class.c@301
PS4, Line 301: 	return OSMO_MIN((num_pdch != 1) ? (128 * num_pdch) : 192, OSMO_MAX(64,
> This code looks unreadable...
lol, I was gonna say "looks fine to me", until I hit the ": 192," --- this is moving previous code around, so we should leave it unchanged, especially since the original formatting was easier to read than this.


https://gerrit.osmocom.org/#/c/6241/4/src/tbf_dl.cpp
File src/tbf_dl.cpp:

https://gerrit.osmocom.org/#/c/6241/4/src/tbf_dl.cpp@1362
PS4, Line 1362: 	uint16_t ws = egprs_window_size(b->ws_base, b->ws_pdch, pcu_bitcount(dl_slots()));
wait, what. This patch:
* moves egprs_window_size() around.
* changes local var use cosmetically.
* *and* changes the last parameter from dl_slots() to pcu_bitcount(dl_slots())?

Please separate into individual patches, don't mix cosmetics with functional change, or it's really hard to figure out what the patch is changing.



-- 
To view, visit https://gerrit.osmocom.org/6241
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings

Gerrit-Project: osmo-pcu
Gerrit-Branch: master
Gerrit-MessageType: comment
Gerrit-Change-Id: Ie411ea2bbfca442b33405584f15687a7ffcbb53c
Gerrit-Change-Number: 6241
Gerrit-PatchSet: 4
Gerrit-Owner: Max <msuraev at sysmocom.de>
Gerrit-Reviewer: Harald Welte <laforge at gnumonks.org>
Gerrit-Reviewer: Jenkins Builder (1000002)
Gerrit-Reviewer: Neels Hofmeyr <nhofmeyr at sysmocom.de>
Gerrit-CC: Pau Espin Pedrol <pespin at sysmocom.de>
Gerrit-CC: Vadim Yanitskiy <axilirator at gmail.com>
Gerrit-Comment-Date: Mon, 05 Nov 2018 03:50:57 +0000
Gerrit-HasComments: Yes
Gerrit-HasLabels: Yes
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/gerrit-log/attachments/20181105/692c819b/attachment.htm>


More information about the gerrit-log mailing list