CalypsoBTS no sync, ms hang

Anton Gorbachev antgorka at gmail.com
Fri May 5 14:52:54 UTC 2017


Dear colleagues,

I am trying to setup CalypsoBTS with two c113 phones.

Don't you know why can't I sync to any commercial cell with transceiver
from branch jolly/testing?

What I have:
Motorola c113 and c113a, tried both.
All other apps like, RSSI, mobile, ccch_scan works like a charm.

What I am doing:
Built jolly/testing according to maual
https://osmocom.org/projects/baseband/wiki/CalypsoBTS

Load firmware
./osmocon -r 99 -m c123xor -p /dev/ttyUSB0 -c
../../target/firmware/board/compal_e88/trx.highram.bin

Found several strongest cells with RSSI and cell_log.
Trying to sync:
./transceiver -a 50 -r 99 -e 1
Here is the log:
50
41
1
<000c> l1ctl.c:77 Tx Reset Req (1)
<000c> l1ctl_link.c:171 Sending: '0d 00 00 00 01 00 00 00 '
<0012> l1ctl.c:383 Reset received: Starting sync.
<000c> l1ctl.c:95 Sync Req
<000c> l1ctl_link.c:171 Sending: '01 00 00 00 00 32 00 64 27 10 03 20 03 07
00 00 00 '

After that phone hangs, no reaction in osmocon on key pressures, holding on
power off button...

The last messages are:
L1CTL_RESET_REQ: FULL!L1CTL_FBSB_REQ (arfcn=50, flags=0x7)
Starting FCCH RecognitionFB0 (2515:4): TOA= 3552, Power= -64dBm, Angle=
1328Hz
FB1 (2525:8): TOA= 8543, Power= -64dBm, Angle=  114Hz
  fn_offset=2523 (fn=2525 + attempt=8 + ntdma = 6)
  delay=8 (fn_offset=2523 + 11 - fn=2525 - 1
  scheduling next FB/SB detection task with delay 8
=>FB @ FNR 2523 fn_offset=2523 qbits=3988
Synchronize_TDMA
LOST 3398!

I tried different cells, maybe I need to wait some time to warm the
crystal? But can it be so important?

Kind regards,
Anton
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/baseband-devel/attachments/20170505/246e325d/attachment.html>


More information about the baseband-devel mailing list