[PATCH] Fix lintian-reported errors

Holger Hans Peter Freyther holger at freyther.de
Wed Mar 25 23:44:23 UTC 2015


On Wed, Mar 25, 2015 at 06:06:01PM +0100, Max wrote:

> -Build-Depends: debhelper (>= 9), autotools-dev, autoconf, automake, libtool, dh-autoreconf, libdpkg-perl, git, doxygen, libpcsclite-dev, pkg-config
> +Build-Depends: debhelper (>= 9), autotools-dev, autoconf, automake, libtool, dh-autoreconf, libdpkg-perl, git, doxygen, libpcsclite-dev, pkg-config, quilt

yes.

>  Description: Open Source MObile COMmunications CORE library
> + Metapackage for Open Source MObile COMmunications CORE library.

Well, this description is not up to standard of Debian. So
we simply fix a warning for the sake of fixing the warning.
Is this really an improvement?

> +Upstream Authors:

sure.

>      GNU General Public License, Version 2 or later
> +    see "/usr/share/common-licenses/GPL-2"

no idea.

>  The Debian packaging is:
>  
>      Copyright (C) 2010 Harald Welte <laforge at gnumonks.org>
> -
> -# Please chose a license for your packaging work. If the program you package
> -# uses a mainstream license, using the same license is the safest choice.
> -# Please avoid to pick license terms that are more restrictive than the
> -# packaged work, as it may make Debian's contributions unacceptable upstream.
> -# If you just want it to be GPL version 3, leave the following lines in.
> -
> -and is licensed under the GPL version 3,
> -see "/usr/share/common-licenses/GPL-3".
> -
> -# Please also look if there are files or directories which have a
> -# different copyright/license attached and list them here.

The copyright file is not up to standards with debian. We silent
the warning without doing the work needed for a debian package. Can
we do it properly?

holger




More information about the baseband-devel mailing list