[PATCH] Fix lintian errors, make .deb build multiarch-aware

Max.Suraev at fairwaves.co
Tue Jul 8 17:46:37 UTC 2014


This patch fixes all the packaging errors reported by lintian and most of the
warnings: see http://openbsc.osmocom.org/trac/wiki/Tasks/MISCDebianPackaging for
details. Few which still remains are either jquery-related (could it be doxygen
error?) or due to lack of manpage (help2man, anyone?)

The patch also adds basic multiarch support - everything should work as it used to be
if you're using pkg_config but review and testing will be greatly appreciated.

N. B. 1: this isn't complete and ready2use multiarch support - just some groundwork
which might be useful later on.

N. B. 2: I don't get at all quilt patching we're using so I've added only dummy
README. Anyone who understands why those patches are not merged to master branch
welcomed to write an explanation.

cheers,
Max.





More information about the baseband-devel mailing list