MS '1' is down, radio is not started

neetesh saxena saxenaneetesh061 at rediffmail.com
Thu Jan 9 16:00:27 UTC 2014


Hi everyone,

Thanks for your help. Now I am able to compile and run the source of osmocmBB. 
The problem was I had not installed toolchain as a root.

But unfortunately, now I m receiving the same error as I was getting earlier which is as follows:
(I am using the "Ja! Mobil" SIM card)

root at neetesh-VirtualBox:/opt/osmocom-bb/src/host/osmocon# telnet localhost 4247
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
Welcome to the OsmocomBB control interface


OsmocomBB> en
OsmocomBB# conf t
OsmocomBB(config)# ms 1
OsmocomBB(ms)#no shutdown
OsmocomBB(ms)#en
OsmocomBB# write
Configuration saved to /home/neetesh/.osmocom/bb/mobile.cfg

OsmocomBB# show ms 1

MS '1' is down, radio is not started
  IMEI: 000000000000000
     IMEISV: 0000000000000000
     IMEI generation: fixed
  automatic network selection state: A0 null
  cell selection state: C0 null

  radio ressource layer state: idle
  mobility management layer state: MM idle, PLMN search

OsmocomBB# show subs 1
Mobile Subscriber of MS '1':
 No SIM present.

OsmocomBB# sim read 1

OsmocomBB# show subs

Mobile Subscriber of MS '1':
 IMSI: 
 Status: U2_NOT_UPDATED  IMSI detached  LAI: invalid
 Access barred cells: no
 Access classes:
I tried the patches SIM in the firmware provided by  Lukas Kuzmiak available at :

http://baseband-devel.722152.n3.nabble.com/patches-for-SIM-in-the-firmware-td4026261.html

But in my first attempt I am getting some error in l23_api.c while I am compileing the osmocomBB source because I think when I am changing the code then I need to recompile and run it.
Didi anyone help me on this? Has anybody used this patch earlier?
Am i doing something wrong?


With regards

Neetesh Saxena...



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/baseband-devel/attachments/20140109/520c14bd/attachment.html>


More information about the baseband-devel mailing list