Motorola C139 V1.9.24 Won't Load from osmocom-bb

Rusty Dekema rdekema at gmail.com
Sun Apr 6 20:09:38 UTC 2014


On Fri, Mar 21, 2014 at 11:39 PM, Rusty Dekema <rdekema at gmail.com> wrote:
> Greetings,
>
> I have a Motorola C139 handset with SW Ver 1.9.24 and a CP2102
> USB/UART adapter, which I hope(d) to use with osmocom-bb.
> [...]

Many thanks for all your help and suggestions. I have tried everything
that was suggested (and more) and have still not been able to load
osmocom-bb onto that particular C139. That said, it has been a good
learning experience.

Although I would still like to eventually get a C139 working (mainly
for its 850 MHz support), I obtained a C118 yesterday and it works
with osmocom-bb like a charm, right out of the box. (It also has at
least some support for the PCS1900 band, which was a pleasant
surprise.) I really appreciate all the work that has gone into this
software, and I'm amazed at how much it can do.

Now, back to the C139. If anyone has any further suggestions, please
let me know. Other than that, I'm mainly sending these responses out
of courtesy and for the benefit of people who may stumble across the
list archive while searching for information on the subject.

> To the OP: in case you haven't already figured it out, you need to use
> -m c140xor with C139 and C140 phones.  I don't know what phones would
> -m c140 (w/o xor) be correct for, if any.  Sylvain's direction to use
> the -c option as well (and then use *.highram.bin instead of
> *.compalram.bin)
> is also correct, because the images are bigger than the ~15k max one
> can download w/o -c on this phone.

Thanks for the info; I tried both of these but got the same result.
The phone never sends a PROMPT1 for reasons discovered later and
described above.


> Also you said your C139 came with fw version "V1.9.24" - are you sure
> it isn't V1.0.24 instead?  The imprint on those stickers is a pain to
> read, too small...

Yes, it's definitely 1.9.24 both on the sticker and the #02# screen.
Additionally, in the #02# screen, there is an item shown that says
either "UART: 1" or "UART Flag: 1". Various forum posts by members of
the unlocking community suggest that this may be an indication that
bootloader/flashing access via the serial port is locked down on a
given handset.


> I had a similar problem with a tracfone branded c139 (ftmtool error). On
> IRC, Hoernchen mentioned an older post where the author "fixed" the
> bootloader. He also mentioned a pastebin that referenced a tool called
> mot931c. I managed to find it and could successfully reflah my tracfone's
> bootloader, which now loads osmocom-bb without issue. Here's the
> reuploaded software package:
>
> https://drive.google.com/file/d/0ByHQWL5Q6bSwdkJReUlJWUQ1Z3M/edit?usp=sharing

When I run the mot931c program, follow the directions, and click
Unlock, I get the output: "Error 2" followed by "Phone not found". Of
note, if I unplug the phone from the computer and do the same, I get
only the "Phone not found" message. Then again, the title of the
mot931c application is "Tracfone mobile unlock 1.0 by Lawer," and mine
is not a Tracfone.


> It should be noted that the new bootloader is very limited (no charging, no
> loading of the regular phone os). I found another tool, called "C139 FULL
> SOLUTION UNLOCK AND FLASH", that successfully could flash a proper
> firmware (European_Software in the archive it is version 1.0.03.E):
> https://drive.google.com/file/d/0ByHQWL5Q6bSwTWdhRFAyU05uLUk/edit?usp=sharing
> Nonethless this particular (trac)phone is still limited to the US bands.

The DLTool/"DM Tool" software in this package does not seem to be able
to "see" or communicate with the phone. After following the directions
and clicking Start, nothing happens for a few minutes after which a
timeout error is shown. Perhaps this is not surprising, since the
mot931c tool was not able to "unlock" whatever it was supposed to
unlock on this phone.


>Has anyone figured out just what this (presumably) closed source
>mot931c.exe binary sends to the phone?

I have not, but I wouldn't mind trying. I do not have any test
equipment for serial communication, but perhaps I could find some
software (or use a VM environment) that would let me observe the
communication between mot931c.exe and the phone. Then again, since
mot931c.exe does not seem to work with the C139 I have, I'm not sure
how much that would help.


Sincerely,
Rusty D




More information about the baseband-devel mailing list