AMR Implementation for Osmocom-BB

Akib Sayyed akibsayyed at gmail.com
Thu Oct 24 14:32:43 UTC 2013


btw Voice uplink works fine


On Thu, Oct 24, 2013 at 8:02 PM, Akib Sayyed <akibsayyed at gmail.com> wrote:

> Hello folks
>
> I am trying to implement AMR codec for osmocom-bb. I got assignment
> commend which is same as
>
> T_AMR_CONFIGURATION amr_param;
>     amr_param.noise_suppression_bit=0;
>     amr_param.initial_codec_mode_indicator=1;
>     amr_param.initial_codec_mode=0;
>     amr_param.active_codec_set=0x95;
>     amr_param.threshold[0]=0x0a;
>     amr_param.threshold[1]=0x10;
>     amr_param.threshold[2]=0x18;
>     amr_param.threshold[3]=0x24;------------just random value
>     amr_param.hysteresis[0]=0x04;
>     amr_param.hysteresis[1]=0x04;
>     amr_param.hysteresis[2]=0x04;
>     amr_param.hysteresis[3]=0x04;----------just copied value from rest
> config for hysteresis
>     l1ddsp_load_amr_param( amr_param);
>
>
>
> Now when i make a call I here gliches or random noise. also after some
> time  there is radio signal loss and call is dropped.
>
>
> I am not getting why this is happening.
> --
> Akib Sayyed
> Matrix-Shell
> akibsayyed at gmail.com
> akibsayyed at matrixshell.com
> Mob:- +91-966-514-2243
>
>


-- 
Akib Sayyed
Matrix-Shell
akibsayyed at gmail.com
akibsayyed at matrixshell.com
Mob:- +91-966-514-2243
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/baseband-devel/attachments/20131024/0d464b25/attachment.html>


More information about the baseband-devel mailing list