Trouble in making CALL

Bhaskar11 niceguy108 at gmail.com
Thu Feb 21 12:28:11 UTC 2013


Hi Chris,

I have had similar problems. Some suggestions you can try out.

1. Put a real IMEI code. Some networks check for "fake" IMEI codes which
were common in some mobiles and refuse connections to those mobiles. Your
case looks like one.  Once it works, you can try to randomise the last few
digits only. Quite possibly this will solve your problem.

2. Put the real IMSI code of your SIM.

3. Do a cold start and try again. Sometimes the connection is unstable. I
have no idea why.

4. Enable "stick" option.

5. Try manual network selection.

6. Put correct SMS service centre number.

Let the list know what works. :-)

Good luck!

B



On Wed, Feb 20, 2013 at 10:21 PM, cris crazy <critsit1234 at gmail.com> wrote:

> Hi,
>
> I'm kindly requesting some suggests for the below issue as i totally don't
> know how to resolve/rectify it.
>
>
> Regards,
> Cris
>
>
> On Tue, Feb 19, 2013 at 2:49 AM, cris crazy <critsit1234 at gmail.com> wrote:
>
>> Hi Andreas,
>>
>> Thanks for your suggestions ...
>>
>> Below is the output after loading the layer1 to mobile
>>
>> OsmocomBB Layer 1 (revision osmocon_v0.0.0-1747-geeafd9f-modified)
>> ======================================================================
>> Device ID code: 0xb4fb
>> Device Version code: 0x0000
>> ARM ID code: 0xfff3
>> cDSP ID code: 0x0128
>> Die ID code: ee180728b042174d
>> ======================================================================
>> REG_DPLL=0x2413
>> CNTL_ARM_CLK=0xf0a1
>> CNTL_CLK=0xff91
>> CNTL_RST=0xfff3
>> CNTL_ARM_DIV=0xfff9
>> ======================================================================
>> Power up simcard:
>> Assert DSP into Reset
>> Releasing DSP from Reset
>> Installing DSP extensions patch
>> Setting some dsp_api.ndb values
>> Setting API NDB parameters
>> Finishing download phase
>> DSP Download Status: 0x0002
>> DSP API Version: 0x3606 0x0000
>> LOST 7089!
>>
>> and i am able to see the layer 1 osmocom-bb in the mobile.
>>
>> As per your suggestion i checked with bcch_scan
>>
>> here is the output snippet from the console of ./bcch_scan
>>
>> arfcn=853 rxlev=1
>> <000c> l1ctl.c:118 FBSB RESP: result=255
>> arfcn=870 rxlev=1
>> <000c> l1ctl.c:118 FBSB RESP: result=255
>> arfcn=876 rxlev=1
>> <000c> l1ctl.c:118 FBSB RESP: result=255
>> arfcn=877 rxlev=1
>> <000c> l1ctl.c:118 FBSB RESP: result=255
>> arfcn=881 rxlev=1
>> <000c> l1ctl.c:118 FBSB RESP: result=255
>> arfcn=882 rxlev=1
>> <000c> l1ctl.c:118 FBSB RESP: result=255
>> arfcn=885 rxlev=1
>> <000c> l1ctl.c:118 FBSB RESP: result=255
>> arfcn=-1 rxlev=0
>>
>> It goes on like this and finally ends with negative value.
>>
>> and in osmocon console the output is like
>>
>> Starting FCCH RecognitionL1CTL_FBSB_REQ (arfcn=849, flags=0x7)
>> Starting FCCH RecognitionL1CTL_FBSB_REQ (arfcn=853, flags=0x7)
>> Starting FCCH RecognitionL1CTL_FBSB_REQ (arfcn=870, flags=0x7)
>> Starting FCCH RecognitionL1CTL_FBSB_REQ (arfcn=876, flags=0x7)
>> Starting FCCH RecognitionL1CTL_FBSB_REQ (arfcn=877, flags=0x7)
>> Starting FCCH RecognitionL1CTL_FBSB_REQ (arfcn=881, flags=0x7)
>> Starting FCCH RecognitionL1CTL_FBSB_REQ (arfcn=882, flags=0x7)
>> Starting FCCH RecognitionL1CTL_FBSB_REQ (arfcn=885, flags=0x7
>>
>>
>> by this i assume that my mobile is not able to sync with the network
>> ..please correct me if i was wrong...
>>
>>
>> and also kindly assist me for any kind of modifications.
>>
>> thanks in advance
>>
>> Regards,
>> Cris
>>
>>
>>
>>
>>
>>
>> On Mon, Feb 18, 2013 at 2:57 PM, jolly <andreas at eversberg.eu> wrote:
>>
>>> cris crazy wrote:
>>> > OsmocomBB# show ms
>>> > MS '1' is up, service is limited
>>> >   IMEI: 418873812577882
>>> >      IMEISV: 4188738125778820
>>> >      IMEI generation: random (15 trailing digits)
>>> >   automatic network selection state: A0 null
>>> >   cell selection state: C0 null
>>> >   radio ressource layer state: idle
>>> >   mobility management layer state: MM idle, PLMN search
>>> hi,
>>>
>>> it seems that you did not yet started your phone, since the network
>>> search has not started. service remains limited until you are attached
>>> to the network, but you don't. did you start layer 1? try bcch_scan and
>>> ccch_scan app to check if your phone works and you can sync to a cell.
>>>
>>> regards,
>>>
>>> andreas
>>>
>>> p.s. please don't make private infos like your IMSI public. they could
>>> be abused.
>>>
>>
>>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/baseband-devel/attachments/20130221/cc8c43fc/attachment.html>


More information about the baseband-devel mailing list