C123 - OSMOCOM RECEIVING BUT NOT SENDING DATA THROUGHT TXD - HARDWARE&SOFTWARE TESTED - GNUARM&OSMOCOM BUILT FROM OSMOCOM PAGE INSTRUCTIONS

Filipe RC - filipe.rc at hotmail.com
Fri Jul 27 00:52:29 UTC 2012








Hi, im having some problems in software only, that i describe bellow in my log:

-FTDI based interface sold by tronix (vendor link on your site), usb2 to serial adaptor ( model TRX1227, CHIPSET FT232R )
-gnuarm&osmocom compiled from source on debian stable as per osmocom without a single problem.
-ran osmocom from su (tried user as well), as instructed and as follows:

$ ./osmocon -p /dev/ttyUSB0 -m c123xor ../../target/firmware/board/compal_e88/loader.compalram.bin

output: 
whenever power button was pressed, all i got was some aparently random hex…(no expert on phone flashing here) with no getting to PROMPT1:

"root at box:/home/box/osmocomm/osmocom-bb/src/host/osmocon# sudo ./osmocon -p /dev/ttyUSB0 -m c123 ../../target/firmware/board/compal_e88/loader.compalram.bin 
got 1 bytes from modem, data looks like: 00  .
got 2 bytes from modem, data looks like: 00 00  ..
got 3 bytes from modem, data looks like: 72 82 bf  r..
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: a6  .
got 1 bytes from modem, data looks like: 51  Q
got 1 bytes from modem, data looks like: d2  .
got 1 bytes from modem, data looks like: 51  Q
got 1 bytes from modem, data looks like: b2  .
got 1 bytes from modem, data looks like: a4  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 4d  M
got 1 bytes from modem, data looks like: a3  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .

2nd press:

got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .

third press:

got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 72  r
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .

fourth press:

got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 72  r
got 1 bytes from modem, data looks like: 82  .
got 1 bytes from modem, data looks like: bf  .
got 1 bytes from modem, data looks like: 7d  }
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: a6  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 00  .
"

Same output, (maybe with a few more presses) in hex, using gtkterm at 115200baud,8bit,nopar,1stop:

"
00 F1 00 72 82 BF 7D FD 7F 00 A6 51 D2 51 B2 A4 12 00 4D A3 A3 68 23 00 00 00 F1 00 72 82 BF 7D FD 7F 00 A6 51 D2 51 A4 A4 12 00 4D A3 A3 68 23 00 00 00 F1 00 72 82 BF 7D FD 7F 00 A6 51 D2 51 B2 A4 12 00 4D A3 A3 64 23 00 00 00 F1 00 72 82 BF 7D FD 7F 00 A6 51 D2 51 A4 A4 12 00 4D A3 A3 64 23 00 00 00 F1 00 72 82 BF 7D FD 7F 00 A6 51 D2 51 B2 A4 12 00 4D A3 A3 48 23 00 00 00 F1 00 72 82 BF 7D FD 7F 00 A6 51 D2 51 B2 A4 12 00 4D A3 A3 64 23 00 00 00 F1 00 72 82 BF 7D FD 7F 00 A6 51 D2 51 B4 A4 12 00 4D A3 A3 48 23 00 00 00 F1 00 72 82 BF 7D FD 7F 00 A6 51 D2 51 A4 A4 12 00 4D A3 A3 48 23 00 00
"
-/dev/USB0 permission check - good, even chmoded 777&chown on rc.local.
-cable check: thought txd was broken, but wasnt. checked from linux
with a led stuck to the txd end of the jack, echo "whatever" > /dev/ttyUSB0, led did flash.
-chances i put are:
osmocom dependent on some specific C123 firmware?
some kind of hidden compilation complication?
some kind of ftdi eeprom config/bitrate/parity config missing for osmocom?

I hope i have managed to be concise enough.
Great work guys.

Greatings from portugal,
Filipe RC




 		 	   		   		 	   		  
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/baseband-devel/attachments/20120727/0da44257/attachment.html>


More information about the baseband-devel mailing list