TCH/H with BB

Leonardo Nve leonardo.nve at gmail.com
Sat Jul 14 01:43:48 UTC 2012


Hi everyone.

I tried to use TCH/H with osmocom-bb (Testing branch) with this configuration on mobile.cfg:


......
......
codec full-speed
codec half-speed prefer
......
......
no full-speech-v1
no full-speech-v2
half-speech-v1
......
......

Trying it over our network (openbsc only with TCH/H timeslots and hr default codecs ) we saw that handsets are still trying TCH/F, is TCH/H supported by bb???
Openbsc log:

Fri Jul 13 20:48:28 2012 <0004> abis_rsl.c:621 (bts=0,trx=0,ts=2,ss=0) RF Channel Release CMD due error 1
Fri Jul 13 20:48:28 2012 <0004> abis_rsl.c:658 (bts=0,trx=0,ts=2,ss=0) RF CHANNEL RELEASE ACK
Fri Jul 13 20:48:30 2012 <0004> abis_rsl.c:594 (bts=0,trx=0,ts=0,ss=0) is back in operation.
Fri Jul 13 20:48:30 2012 <0004> abis_rsl.c:1281 BTS 0 CHAN RQD: no resources for TCH/F 0xdf
Fri Jul 13 20:48:30 2012 <0019> ipaccess.c:426 Bad signalling message,sign_link returned error: 0c 13 01 88 13 df 03 31 11 0c 
Fri Jul 13 20:48:30 2012 <0004> abis_rsl.c:594 (bts=0,trx=0,ts=2,ss=0) is back in operation.
Fri Jul 13 20:48:39 2012 <0004> abis_rsl.c:1281 BTS 0 CHAN RQD: no resources for TCH/F 0xdf
Fri Jul 13 20:48:39 2012 <0019> ipaccess.c:426 Bad signalling message,sign_link returned error: 0c 13 01 88 13 df 09 f5 11 0c 
Fri Jul 13 20:48:51 2012 <0004> abis_rsl.c:1281 BTS 0 CHAN RQD: no resources for TCH/F 0xdf
Fri Jul 13 20:48:51 2012 <0019> ipaccess.c:426 Bad signalling message,sign_link returned error: 0c 13 01 88 13 df 1c 31 11 0c






More information about the baseband-devel mailing list