osmocombb and usrp

Martin Janovský martian at seznam.cz
Tue Feb 14 07:58:08 UTC 2012


Hi Peter and others,

Yes, I had enabled the software sim before trying to associate with the 
BTS. I also defined my IMSI and rebooted the phone afterwards.

Maybe, I'd like the people here to answer these questions for me, if 
possible:

Is the "test sim/soft sim/testcard" feature fully functional in the 
current release of OsmocomBB?
(I want to try couple scenarios with a OpenBSC test setup that another 
student has been running at our faculty. I'm setting up a OpenBTS/USRP 
scenario too.)

Is the sim reader feature in the "mobile" app currently able to work 
with HW sim cards?
(I want to try running the FOSS firmware as a normal phone for a bit.)

If my Motorola C123 is sim-locked to some German service provider, do I 
have to find ways to unlock it to be able to run a Czech sim card or 
does the OsmocomBB firmware override the sim lock by default?
I think I was unsuccessful last time I tried popping one in and enabling 
it through "OsmocomBB mobile". I can provide more info after I've 
re-tried this.

I hope my questions stick to the spirit of this list well enough, if 
not, please let me know.

Thanks,
Martin

Dne 13.2.2012 18:22, Peter Stuge napsal(a):
> Martin Janovský wrote:
>> OsmocomBB# show ms
>> MS '1' is up, service is limited
>>    IMEI: 000000000000000
>>       IMEISV: 0000000000000000
>>       IMEI generation: fixed
>>    manual network selection state   : M5 no SIM inserted
> This looks bad. Did you enable the sim?
>
>
> //Peter
>





More information about the baseband-devel mailing list