Arkmicro Technologies Inc. ARK3116 Serial

Darran.Lee darranpr at yahoo.com
Fri Apr 27 23:19:50 UTC 2012


Hi
I am trying to use an Arkmicro Technologies ARK3116 USB to serial cable to communicate with my C118. I have compiled Osmocom-bb successfully on my Debian Squeeze laptop.
When I try to run the osmocon utility I get an error "Cannot open serial device /dev/ttyUSB0"
My dmesg etc output is:
[  769.752182] usb 5-2: new full speed USB device using uhci_hcd and address 5
[  769.908979] usb 5-2: New USB device found, idVendor=6547, idProduct=0232
[  769.908988] usb 5-2: New USB device strings: Mfr=1, Product=3, SerialNumber=0
[  769.908995] usb 5-2: Product: USB-UART Controller
[  769.909000] usb 5-2: Manufacturer: ArkMicroChips
[  769.909192] usb 5-2: configuration #1 chosen from 1 choice
[  770.029492] usbcore: registered new interface driver usbserial
[  770.029740] USB Serial support registered for generic
[  770.030002] usbcore: registered new interface driver usbserial_generic
[  770.030005] usbserial: USB Serial Driver core
[  770.047650] USB Serial support registered for ark3116
[  770.048263] ark3116 5-2:1.0: ark3116 converter detected
[  770.076254] usb 5-2: ark3116 converter now attached to ttyUSB0
[  770.076305] usbcore: registered new interface driver ark3116

ls -l /dev/tty*
crw-rw---- 1 root dialout   4, 64 Apr 27 21:01 /dev/ttyS0
crw-rw---- 1 root dialout   4, 65 Apr 27 21:01 /dev/ttyS1
crw-rw---- 1 root dialout   4, 66 Apr 27 21:01 /dev/ttyS2
crw-rw---- 1 root dialout   4, 67 Apr 27 21:01 /dev/ttyS3
crw-rw---- 1 root dialout 188,  0 Apr 27 21:14 /dev/ttyUSB0

lsusb 
Bus 005 Device 005: ID 6547:0232 Arkmicro Technologies Inc. ARK3116 Serial
Bus 005 Device 004: ID 09da:0006 A4 Tech Co., Ltd Optical Mouse WOP-35 / Trust 450L Optical Mouse
Bus 005 Device 003: ID 1631:5002 Good Way Technology 
Bus 005 Device 002: ID 1631:5400 Good Way Technology 
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
So I am assuming the drivers are installed correctly but if I run osmocon I get:
./osmocon -p /dev/ttyUSB0 -m c123xor ../../target/firmware/board/compal_e88/loader.compalram.bin 
Cannot open serial device /dev/ttyUSB0
My Question is, does anyone here have any experience with the Arkmicro Technologies ARK3116 Serial cable?
Is there something I have missed?
Thanks
Tokala
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/baseband-devel/attachments/20120427/7d8da1c0/attachment.html>


More information about the baseband-devel mailing list