mobile - making a call

eisencah eisenach wbg_1000 at yahoo.com
Tue May 3 10:02:58 UTC 2011


The difference between the cases that work and the ones that don't is :

GOOD CASE:
<0004> gsm48_mm.c:1533 AUTHENTICATION REQUEST (seq 0)
<0004> subscriber.c:898 Generating KEY at SIM
<000e> sim.c:209 got new job: SIM_JOB_RUN_GSM_ALGO (handle=00000006)
<000e> sim.c:538 RUN GSM ALGORITHM
<000e> sim.c:187 sending APDU (class 0xa0, ins 0x88)

BAD CASE:
<0004> gsm48_mm.c:1533 AUTHENTICATION REQUEST (seq 1)
<0004> subscriber.c:898 Generating KEY at SIM
<0001> gsm48_rr.c:4488 Indicated ta 0 (actual ta 0)
<0001> gsm48_rr.c:4490 Indicated tx_power 5

So is as if the message for the sim job doesn't get pulled from the queue, "got new job: SIM_JOB_RUN_GSM_ALGO " never appears.  Must say the computer I use osmocom on is not exactly a rocket :) (is a 500Mhz celeron with ubuntu 6.10) , and It gets slowed down when running the hole thing. Can that be the cause?
Mihai.


--- On Tue, 5/3/11, Sylvain Munaut <246tnt at gmail.com> wrote:

From: Sylvain Munaut <246tnt at gmail.com>
Subject: Re: mobile - making a call
To: "eisencah eisenach" <wbg_1000 at yahoo.com>
Cc: baseband-devel at lists.osmocom.org
Date: Tuesday, May 3, 2011, 9:32 AM

> So is this normal at the current stage of the project or there's something wrong with my setup ? (and all the calls where suppose to advance to the alert phase)

Nope, it should work.

No idea why it doesn't for you.


    Sylvain
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/baseband-devel/attachments/20110503/03d1769c/attachment.html>


More information about the baseband-devel mailing list