hmm, sorry, data cable question

n0p [Luis Bernal] lbernal at gmail.com
Tue May 24 13:04:52 UTC 2011


what serial port are you using?
usb-serial? a laptop one?

you are not frying your mobile only because you are lucky: your com port
fails to deliver the 12~15v standard to the rs232 and delivers 5v instead

so the 7805 regulator fails to deliver 5v because it's a linear regulator
with a high drop out (internal voltage loss- it is designed to work at at
least 6 or 7v ) plus the diodes voltage drop and it's delivering 3.4v

if your connect that cable to a good com port, it will drive the calypso at
5v and it will fry it. right now is delivering 2.5v on tx, and it seems
that's just enough to drive the calypso serial

TL;DR: get a usb->ttl3.3v cable and forget this one

also, did anyone tried attaching a phone to a 5v cable to see if it really
dies?

2011/5/24 Roy <roytiberius at gmail.com>

> these are my voltage measurements
>
>
> http://baseband-devel.722152.n3.nabble.com/file/n2979519/Motorola_T191_unlock_cable_interface_by_Roy_Volts_Measurement.jpg
>
> --
> View this message in context:
> http://baseband-devel.722152.n3.nabble.com/hmm-sorry-data-cable-question-tp2419703p2979519.html
> Sent from the baseband-devel mailing list archive at Nabble.com.
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/baseband-devel/attachments/20110524/4b45043c/attachment.html>


More information about the baseband-devel mailing list