Cygwin Windows --> Accessing serial port.

R M rm.engineer84 at gmail.com
Mon Jun 6 18:10:21 UTC 2011


Hi,

Thanks.

I was able to access the serial port.

I ran the following command

./osmocon -p /dev/ttyS5 -m c123xor
 ../../target/firmware/board/compal_e88/hello_world.compalram.bin in cygwin

I then held the power on button of the phone for some time. I got some
output on the cygwin console.It isn't the expected output as per the wiki.

 After disconnecting, I tried to run the same command and nothing is
happening.

Can some one please suggest me what steps I need to take to solve the
problem.

I am using  Motorola C115 phone.

Regards,
RM
On Sat, Jun 4, 2011 at 12:12 PM, Dieter Spaar <spaar at mirider.augusta.de>wrote:

> Hello Harald,
>
> On Sat, 4 Jun 2011 08:46:50 +0200, "Harald Welte" <laforge at gnumonks.org>
> wrote:
> >
> > i have never heard of somebody doing this on windows 7.  Almost everyone
> > here uses Linux or MacOS.  And the only prominent Windows user involved
> > in the project is working with Windows XP.
>
> At least on my Cygwin installation under Windows XP the serial port
> is accessible as "/dev/ttySx" (x is "0" for COM1, "1" for COM2 and
> so on). All the USB to serial converters I am aware of are virtual
> COM ports on Windows which means that they are accessible the same
> way, e.g. if the virtual COM port is "COM7" it can be be accessed
> as "/dev/ttyS6",
>
> Best regards,
>  Dieter
> --
> Dieter Spaar, Germany                           spaar at mirider.augusta.de
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/baseband-devel/attachments/20110606/080d2d37/attachment.html>


More information about the baseband-devel mailing list