AW: The call has been rejected

josephli josephli1029 at hotmail.com
Mon Jul 18 08:06:59 UTC 2011


This is when I try to read sim card in VTY:

root at gsm-desktop:~# telnet localhost 4247
Trying ::1...
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
Welcome to the OsmocomBB control interface
OsmocomBB> en
OsmocomBB# sim reader 1
OsmocomBB# 
% (MS 1)
% SIM failed, replace SIM!

Any way, I was asked to replace the sim card.

This is when I check the MS 1 status:

show ms
MS '1' is up, service is limited
     IMEI: 000000000000000
     IMEISV: 0000000000000000
     IMEI generation: fixed
  automatic network selection state: A6 no SIM inserted
  cell selection state: C7 camped on any cell (ARFCN 115)
  radio ressource layer state: idle
  mobility management layer state: MM idle, no IMSI

Thing is like the MS is fixed on the frequency band which mnc==01 is
allocated. The way I did next is to replace the SIM card that belongs to the
service of mnc==01 and it worked fine when I run the command of "sim reader
1". 

I suspect that when the phone is in idle status, it scans the frequency band
with strongest RSSI. After the VTY activated the sim card, the call connects
as long as the frequency band and the sim card belonging to the same service
provider. Is that the way it temporary works?

Regards,

Li 

  


--
View this message in context: http://baseband-devel.722152.n3.nabble.com/The-call-has-been-rejected-tp3171584p3178448.html
Sent from the baseband-devel mailing list archive at Nabble.com.




More information about the baseband-devel mailing list