What I am doing wrong? G2

Панфилов Дмитрий dmytrop at mail.ru
Mon Jan 31 14:10:27 UTC 2011


Hi!
So, I decide to play with my G2 SciPhone
(My phone has configuration as follows: 512Mb (64MB) NAND + 32MB RAM)
But I could not run U-Boot...

The first step seems to be good. I run Osmocon and download "loader" to the phone.
I got "Running on mt62xx in environment mtkram HW_CODE = 0x6235" message.

After executing $ ./osmoload memload 0x500000 u-boot.bin
I can see progress and successfull download of u-boot.bin

First of all I tried to use u-boot from here
 http://downloads.qi-hardware.com/people/marcin/g2_uboot.bin (http://downloads.qi-hardware.com/people/marcin/g2_uboot.bin) 

Executing $ ./osmoload jump 0x500000 leads to... nothing. I can see black screen. That's all.

Also I compilled u-boot from git using toolchain kindly given by Andrew :-)

$ ./osmoload jump 0x500000 leads to gray screen after flashing white for a moment.
It looks like wrong LCD controller or driver.

So... The simple question. What I am doing wrong? :)

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/baseband-devel/attachments/20110131/0754db27/attachment.html>


More information about the baseband-devel mailing list