problems getting Pirelli DP-L10 to work

Leif Jakob jakob at weite-welt.com
Sun Jan 23 23:44:17 UTC 2011


Hi,

maybe I'm missing something, but when I read that the Pirelli DP-L10
would be supported I tried to get it running:

I didn't patch my usb-module, but used:

modprobe -v cp210x
echo "0489 e003" > /sys/bus/usb-serial/drivers/cp210x/new_id

from the steve-m/testing-branch I compiled the firmware and loaded it with

./host/osmocon/osmocon -p /dev/ttyUSB0 -m romload target/firmware/board/pirelli_dpl10/hello_world.highram.bin 

onto the phone... that worked but I was never able to see any messages
after the upload:

Received block ack from phone
Sending checksum: 0xaa 
Checksum on phone side matches, let's branch to your code
Branching to 0x00820000
Received branch ack, your code is running now!

... there it stayed forever ...

I'm pretty sure that the code runs, because I commented in init.c the
keyboard lighting code and it didn't light up after upload. I've tried
other bins but to no success.

Any hint or am it too early playing with that hardware?

Greetings Leif







More information about the baseband-devel mailing list